Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Not able to configure environments properly

Highlighted
Amanjyot
Super Collector

Not able to configure environments properly

Hi Folks,

 

We are facing following error while doing environment check. We are on 9.14 with windows 2008 R2 server.

 

ERROR: Could not logon to [Server_name].
Server reports version SSH-2.0-OpenSSH_6.7
which is incompatible with SSH 1.5

 

 

Any pointer on this please?

 

 

Cheers,

Aman

5 REPLIES
Loc_Nguyen_PPM
Occasional Visitor

Re: Not able to configure environments properly

Hi Aman,

 

Here is some confirm from HP support.


You are using OpenSSH 6.7, which does not work by default with PPM SSH2 client, even with the new SSH2 client introduced in PPM 9.22.0001 and 9.30. The reason is that PPM doesn't support the Key Exchange protocols that OpenSSH  includes by default in its latest version.

This issue was fixed in PPM 9.31, but the workaround is to add the Key Exchange protocols supported by PPM in your OpenSSH configuration if you are using 6.7.  You can do so by adding the following line in sshd_config:
 
KexAlgorithms ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha1,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1
 
You can refer on this link from the SSH2 library that PPM uses in the new SSH2 client: http://sourceforge.net/p/jsch/bugs/79/

 

 

Hope this helps,

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
Amanjyot
Super Collector

Re: Not able to configure environments properly

Hi,

 

I added the line in the file but no luck. I am getting the same error.

 

 

Thanks,

Aman

Loc_Nguyen_PPM
Occasional Visitor

Re: Not able to configure environments properly

Hi,

 

Did you try to restart sshd after added this line ?

 

 

Regards,

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
Amanjyot
Super Collector

Re: Not able to configure environments properly

The service, right?

 

Yes, i  did but no luck.

 

When i use ssh2 it pops an error :

 

ERROR: Could not logon to [SERVER_NAME].
Unsupported key exchange algorithms requested: curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha1,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1

 

When i use ssH the error is :

 

ERROR: Could not logon to [SERVER_NAME].
Server reports version SSH-2.0-OpenSSH_6.7
which is incompatible with SSH 1.5

 

 

Thanks,

Aman

TJXCoons
Acclaimed Contributor

Re: Not able to configure environments properly

Was this resolved because I have the same issue which I got when upgrading ssh.   I tried the fix in the sshd_config, restarted sshd and now get

 

Unsupported key exchange algorithms requested: ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha1,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1

 

I think all I need is the the exchange algorithms ppm 9.14 supports

//Add this to "OnDomLoad" event