Project and Portfolio Management Practitioners Forum
cancel

Modifying request table and flushing caches

SOLVED
Go to solution
Highlighted
Cenk Oguz
Respected Contributor.

Modifying request table and flushing caches

Hi,

I am having a custom report modifying the request fields of projects. The modification is done by adding a row to a request table component (KCRT_TABLE_ENTRIES).

The problem is, I am having problems flushing the cache afterwards, meaning the modification is not visible. It is a cluster, and it seems the main node is having its caches cleared as changes are visible immediately, but the other nodes are not having the changes visible immediately.

I am using "kRunCacheManager A" for flushing all caches.

Anyone having any experiences here?

BR,
Cenk
7 REPLIES
Raj Ghimire
Outstanding Contributor.

Re: Modifying request table and flushing caches

I hope you are also updaing the "last_update_date" fild if applicable.
-Raj
Cenk Oguz
Respected Contributor.

Re: Modifying request table and flushing caches

Yes the last update fields are set to SYSDATE. But that shouldn't have any effect on clearing out caches.

/Cenk
Erik Cole
Acclaimed Contributor.

Re: Modifying request table and flushing caches

I'm not sure that kRunCacheManager will automatically detect a cluster and flush them all.

However, if you update the LAST_UPDATE_DATE & LAST_UPDATED_BY in kcrt_requests and kcrt_request_details tables too then the servers should all know their cached data for this request is outdated without having to do a manual flush...
Cenk Oguz
Respected Contributor.

Re: Modifying request table and flushing caches

Well it not appear to solve the issues just by updating the last_update_date in KCRT_REQUESTS and KCRT_REQUEST_DETAILS.

The caches still seemed to need a manual clearing.

Although it seems to work out in some web sessions, but not in all sessions. Hard to grasp exactly how the ppm servers work out here.
Michael.Ebert
Super Contributor.
Solution

Re: Modifying request table and flushing caches

Hi Cenk,

indeed the clustered environment could be an issue.
Try to disable the table entry cache in all servers of clustered environment in
/conf/tune.conf
edit the following line and set cache size to zero
com.kintana.core.server.TABLE_ENTRY_CACHE_SIZE = 0

Regards
Michael
Cenk Oguz
Respected Contributor.

Re: Modifying request table and flushing caches

Thanks Michael,

disabling the table entries cache indeed solved the problem. Only question is what performance impact one would see by disabling this particular cache.

BR,
Cenk
vatsan
Valued Contributor.

Re: Modifying request table and flushing caches

Alternatively, is there a command to flush the table_entry_cache? I've faced this problem earlier and flushing the cache with the available commands just flushes the request details cache and not the table component's. Thanks!