Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Message "Please enable REST support in WEB-INF/conf/axis2.xml and WEB-INF/web.xml"

Highlighted
PPMRam
Collector

Message "Please enable REST support in WEB-INF/conf/axis2.xml and WEB-INF/web.xml"

Hi,

 

We have added parameter "ENABLE_WEB_SERVICES=true" to server.conf . But when we access wsdl from dashboard, it is giving message "

Please enable REST support in WEB-INF/conf/axis2.xml and WEB-INF/web.xml"

 

. Can we use web services eventhough it is showing this message or do we need to modify any settings inorder to display wsdl xml page and inorder to work with web services. Can anyone please respond ASAP.

 

Thanks

Shravan

2 REPLIES
AlexSavencu
Honored Contributor

Re: Message "Please enable REST support in WEB-INF/conf/axis2.xml and WEB-INF/web.xml"

Hi,

 

did you find a solution to this issue?

 

cheers

alex


--remember to kudos people who helped solve your problem
Pogonchev
HPE Expert

Re: Message "Please enable REST support in WEB-INF/conf/axis2.xml and WEB-INF/web.xml"

Hi Shravan,

 

You could try to edit axis2.xml and set the <parameter name="enableRESTInAxis2MainServlet" locked="true">true</parameter>. 

Then try to access the wsdl using the following link:

 

http://<host>:<port>/itg/ppmservices/wsdl/DemandService?wsdl

 

instead of

 

http://<host>:<port>/itg/ppmservices/DemandService?wsdl

 

I hope this helps.

 

Best regards,

 

Nikola

 


HPE Support

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
//Add this to "OnDomLoad" event