Project and Portfolio Management Practitioners Forum
cancel

Maximum Rows in Portlet Maximizied View

Highlighted
Sangiliraja_1
Honored Contributor.

Maximum Rows in Portlet Maximizied View

Hi,

I have set the maximum rows to be displayed in portlet to 1000. In one of the portlet i was trying to enter 500 in this field "Rows Displayed in Maximized View: ". But PPM is not allowing to do that. So i think there is a limitation in PPM on number of rows displayed in maximized in one page.

Is there any setting that can be done to increase this.

Thanks
Sangiliraja.P
12 REPLIES
sam.greg
Honored Contributor.

Re: Maximum Rows in Portlet Maximizied View

Yeah, I have observed same issue in our portlets. May be its a limitation.

Additionally, I have also observed, that keys left-arrow, right-arrow do not work.


Regards,
Sam
Sangiliraja_1
Honored Contributor.

Re: Maximum Rows in Portlet Maximizied View

Hi Sam,

Thanks for your inputs.

Thanks
Sangiliraja.P
Deep Mehta
Respected Contributor.

Re: Maximum Rows in Portlet Maximizied View

Hi Sangiliraja,

you will need to change the server.conf file setting PORTLET_MAX_ROWS_RETURNED. Default is 200.

Good Luck,
Deep
Niraj Prabhu
Outstanding Contributor.

Re: Maximum Rows in Portlet Maximizied View

Hi Sangiliraja,

1. Add following parameter in server.conf file PORTLET_MAX_ROWS_RETURNED.
Default value is 200.

2. Bounce the server.

3. run kUpdateHtml.sh

4. Start the server and test this.

Regards,
Niraj
Niraj P.
Sangiliraja_1
Honored Contributor.

Re: Maximum Rows in Portlet Maximizied View

Hi Guys,

I am looking for displaying more than 200 rows in one page in maximized view of the portlet.

Is it possible?

Thanks
Sangiliraja.P
Deep Mehta
Respected Contributor.

Re: Maximum Rows in Portlet Maximizied View

Hi Sangiliraja,

I think its possible. Did you update the server.conf file?
200 value is default. You can have 500 too in there.

**Please note that this setting will affect all the portlets and can have adverse effects on portlet performance.

Thanks,
Deep
Nisha Kurien
Honored Contributor.

Re: Maximum Rows in Portlet Maximizied View

Hi Sangiliraja,

When you edit the portlet, do you see the option "Rows Displayed in Maximized View: "

I'm able to set this value to 1000 or even more. Screenshot attached.

Is this a custom portlet or OOTB one?

- Nisha Kurien


Sangiliraja_1
Honored Contributor.

Re: Maximum Rows in Portlet Maximizied View

Hi All,

thanks for your reponses.
OOTB porltets are working fine after the change in server,conf.

But my custom portlets are still not allowing more than 200.

Thanks
Sangiliraja.P
Niraj Prabhu
Outstanding Contributor.

Re: Maximum Rows in Portlet Maximizied View

Check your Data Source and Portlet Definition one more time. It should work this time.

Regards,
Niraj
Niraj P.
Sangiliraja_1
Honored Contributor.

Re: Maximum Rows in Portlet Maximizied View

Hi Niraj,

I just checked. It is not allowing me to enter more than 200.

Did you tried for a custom portlet.

Thanks
Sangiliraja.P
PawanW
Contributor.

Re: Maximum Rows in Portlet Maximizied View

This happens if group by cluase section is empty in the datasource. This is a PPM limitation. The work around is as follows.
In the group by clause of datasource, add a comment e.g. /*This comments is added to fetch more than 200 rows*/ and this should solve your problem.
Mahen M
Acclaimed Contributor.

Re: Maximum Rows in Portlet Maximizied View

Alternatively we can add a filter for Row Number as attached in the screen shot.

Regards,
Mahendran M