Project and Portfolio Management Practitioners Forum
cancel

Java out of swap space error

Highlighted
Kerim KILIC
Frequent Visitor

Java out of swap space error

Hi all,

 

Im facing an issue with java process, it is randomly terminated and does not create any error in the logs if i stat it via windows service. If i start via cygwin, when it terminates it throws out of swap space error. I tried to increase heap size, swap space in windows and increate workers thread parameter in server.conf but no luck, still java process terminates randomly.

 

Anyone face this issue?

 

Regards

Kerim

4 REPLIES
Utkarsh_Mishra
Honored Contributor

Re: Java out of swap space error

Can you please share the JAVA version and PPM version
Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
Kerim KILIC
Frequent Visitor

Re: Java out of swap space error

i tried with java 1.6.07,1.6.26 version and ppm 9.1.1

Renju_Babu
Occasional Contributor

Re: Java out of swap space error

Hi,

       The issue may be because you have java process still running even if you stop the PPM Services through Windows Services/Cygwin.

Please kill the java process and restart the PPM Services.Hope this will resolve your issue.

Inorder to kill the Java Process you can use the tool Process Explorer which will show a Java Exe file which is running even after you stopped the services through the cygwin or Windows Services.

Hope this helps.

 

Renju

AlexSavencu
Honored Contributor

Re: Java out of swap space error

Hi, Kerim,

 

- increasing the worker threads will definitely not help, since they will require more memory.

- increasing windows swap will again not help, since it is managed by windows, and java has no control whatsoever.

 

This error has no relation to other instances of the java process.

 

I think the solution is to increase the heap size AND the perm size - usually, this is required in PPM for a large implementation and ”it should be performed only when advised by HP Support”. If this is really the case, the best option for you is to implement an extra PPM node in a cluster configuration, AND configure one node for services and one node for users.

 

hope this helps.

 

cheers

alex


--remember to kudos people who helped solve your problem
//Add this to "OnDomLoad" event