Project and Portfolio Management Practitioners Forum
cancel

JBoss upgrade in HP PPM

SOLVED
Go to solution
Highlighted
SudeepSP
Contributor.

JBoss upgrade in HP PPM

Hello,

 

I am using PPM 9.14 for my deployments. The JBoss version used currently for PPM 9.14 is  JBoss version: 4.0.5.GA . As per my company audit policy I need to upgrade my JBoss current version to JBoss 5.x / 6.x / 7.x / Wildfly (8.x). 

 

Please let me know if any impact in upgrading the JBoss for PPM 9.14, also the link with  steps and document for the same. 

 

Note: I will also upgrade my PPM to 9.22 in another 3 months.

 

Thanks!

2 REPLIES
Etienne_Canaud
Outstanding Contributor.
Solution

Re: JBoss upgrade in HP PPM

Hi,

 

JBoss is tightly integrated with PPM 9.1X and 9.2X and cannot be upgraded or replaced by another application server. You should think of PPM as a black box, from which internal components are not to be modified by PPM admins.

 

Your only option is to upgrade to PPM 9.30 in which JBoss has been removed and replaced by Tomcat 7.0.42.

 

This is a very impacting change and there's no plan to do the same with PPM 9.1X or 9.2X.

 

Kind Regards,
Etienne.

SudeepSP
Contributor.

Re: JBoss upgrade in HP PPM

Thank you Etienne .