The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

JBOSS, how to bind a specific IP address

Highlighted
jerome.vovard
Regular Collector

JBOSS, how to bind a specific IP address

How could i set PPM 7.5 to listen the right IP address (Virtual Ip address)?
Here is my environnement:
Server Unix AIX 5.3, JDK 1.5 , Oracle 10.2.0.3
, PPM 7.5 SP1

Everything is already installed and works correctly.

But we saw that PPM was listening all the virtual ip addresses of the server. It supposed to listen its Virual IP only.
How can I do this?

Just to be clear: the server has 4 network devices, only one physical Ip Address (192.68.128.122), and 20 virtuals Ip Addresses (One of them is assigned to PPM: 192.66.20.20). We generated a PPM license with this virtual IP address.

Here is the Unix command which I invoked to install PPM:
./install.sh -console -W LicenseConf.value="/applis/ppmd/bin/SOCGEN.conf" -W LicenseConf.active="false"

Once the install was finished, i added the following statement to the server.conf:
LOCAL_IP=192.68.128.122

Then I started PPM. No error, PPM works correctly.
I ran the following unix command:
lsof |grep ppmdadm | grep LISTEN
And got this result:
java 8085585 ppmdadm 140u IPv4 0xf1000600056b2398 OtO TCP *:44597 (LISTEN)
java 8085585 ppmdadm 170u IPv4 0xf1000600055d0398 OtO TCP *:7001 (LISTEN)
java 8085585 ppmdadm 389u IPv4 0xf100060005995398 OtO TCP DPPMD.dns21.SOCGEN:rmiregistry (LISTEN)

In the both first rows, we should see DPPMD.dns21.SOCGEN instead of the start (*) character.

This server contains a lot of other applications which are using the same port but a unique virtual IP.
That's why we want to force PPM to listen one IP address and one port.

I guess this * character should be generated by a config file of PPM.
DO you know it? Which config file? How can I manage this issue?
In the jbossweb-tomcat50.sar, the server.xml contains a variable jboss.bind.address: what does it mean?

Note: the 7001 port is used for the client PPM URL.
DPPMD.dns21.SOCGEN is the DNS
Ppmdadm is the unix account used by me to install PPM.

Regards,
Sorry for this short description ;-)
3 REPLIES
Erik Cole_1
Esteemed Contributor

Re: JBOSS, how to bind a specific IP address

Hi Jerome,

Are you using the IP address in the following server.conf parameter:

com.kintana.core.server.SERVER_NAME
jerome.vovard
Regular Collector

Re: JBOSS, how to bind a specific IP address

Hi, the Server_name parameter is not link to the IP address.
However, I used the default value to my server.conf for this parameter:
com.kintana.core.server.KINTANA_SERVER_NAME=kintana
jerome.vovard
Regular Collector

Re: JBOSS, how to bind a specific IP address

I got it.
//Add this to "OnDomLoad" event