Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Increase report timeout

Highlighted
Sebas Prieto
Occasional Advisor

Increase report timeout

Can i increase timeout value for reports using a server.conf parameter?

does "com.kintana.core.server.REPORT_EXEC_TIMEOUT" parameter exist?

thanks
2 REPLIES
StefanBienz
Super Collector

Re: Increase report timeout

Hi,

If you are talking about the timeout for a COMMAND in the report, then you have to go to that particular Report Type and edit the Timeout there (like in a Request Command, in seconds)
Workbench->Configuration->Report Types->"Open the Report Type"->Commands->Timeout(s).

I don't see the need of a general Timeout Parameter here, because every Report Type has its own commands and therefore its own timeouts.

Hope that helps,

Stefan Bienz
Cirrus Consulting AG
Darshan Bavisi
Occasional Visitor

Re: Increase report timeout

Hi Sebas,

You can either increase the time out on commands in each report where you are having this issue or try adding this parameter in the server.conf file with your required time out in seconds,

com.kintana.core.server.DEFAULT_COMMAND_TIMEOUT=180

*replace 180 with what time you need in seconds.

I don't think the REPORT_EXEC_TIMEOUT exists, but the above one may be of help in the same way.

Thanks,
Darshan
//Add this to "OnDomLoad" event