The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Import Users : User Error:INVALID_USER

Highlighted
Long Xuong
Occasional Contributor

Import Users : User Error:INVALID_USER

Hi all
I imported new user to PPM by using
Import report to load new user into PPM.
I got this error message:
User Security Details


Security Group Name Transaction Id Action Process Phase Process Status
PDE - All Users 1436 Validating Errored(specific error) F
User Error:INVALID_USER:User (test4.palla@valuelabs.net) does not exist in HP Project and Portfolio Management system.
It's a new user why the import report complains that this user does not exist in PPM?

Thanks a lot
11 REPLIES
Erik Cole
Honored Contributor

Re: Import Users : User Error:INVALID_USER

You can get an error like this if you're importing users and user B is listed as user A's manager and user A is imported before user B.
Long Xuong
Occasional Contributor

Re: Import Users : User Error:INVALID_USER

Hi Erik
The resource's manager has been loaded into PPM before this user. Do you know why I still get that error message?
Thanks a lot for your help
Erik Cole
Honored Contributor

Re: Import Users : User Error:INVALID_USER

Do you have anything in KNTA_INTERFACE_ERRORS?

Do you have someone listed in KNTA_USER_SECURITY_INT that isn't in KNTA_USERS_INT?
Long Xuong
Occasional Contributor

Re: Import Users : User Error:INVALID_USER

Hi Erik
Thanks a lot for your help.
Here's information in knta_users_int,
knta_user_security_int and KNTA_INTERFACE_ERRORS for you to review

1) knta_users_int
select username from knta_users_int

Username
test7.palla@valuelabs.net
test6.palla@valuelabs.net
2)knta_user_security_int

select logon_identifier, username, security_group_name, user_security_action from knta_user_security_int
LOGON_IDENTIFIER,USERNAME,SECURITY_GROUP_NAME,USER_SECURITY_ACTION
test7.palla@valuelabs.net,test7.palla@valuelabs.net,PDE - All Users,ADD

After ran the import report to load new users
I got the following message from the report

User Name Logon Id Transaction Id Existed Process Phase Process Status
test6.palla@valuelabs.net test6.palla@valuelabs.net 1442 F Completed Completed
test7.palla@valuelabs.net test7.palla@valuelabs.net 1440 F Completed Completed
User Security Details
Security Group Name Transaction Id Action Process Phase Process Status
PDE - All Users 1441 Validating Errored(specific error) F
User Error:INVALID_USER:User (test7.palla@valuelabs.net) does not exist in HP Project and Portfolio Management system.

and here's the error in the KNTA_INTERFACE_ERRORS

select * from KNTA_INTERFACE_ERRORS

INTERFACE_ERROR_ID,INTERFACE_TABLE_NAME,INTERFACE_SOURCE_ID,GROUP_ID,CREATION_DATE,MESSAGE_TYPE_ID,MESSAGE_NAME,MESSAGE
46558,KNTA_USER_SECURITY_INT,1441,19,10/03/2009 3:55:48 PM,10,INVALID_USER,User (test7.palla@valuelabs.net) does not exist in HP Project and Portfolio Management system.

Thanks again ..

Xuong Long


Erik Cole
Honored Contributor

Re: Import Users : User Error:INVALID_USER

Okay I think I see the problem. It looks like you are trying to add test7 as a user and add the security group at the same time. I believe you have to do this in two separate transactions. Now that test7 is in the system, you should be able to run the report again to add the security group.
Long Xuong
Occasional Contributor

Re: Import Users : User Error:INVALID_USER

HI Erik
I reran the import report I got this error

User Name Logon Id Transaction Id Existed Process Phase Process Status
test6.palla@valuelabs.net test6.palla@valuelabs.net 1442 T Completed Completed
test7.palla@valuelabs.net test7.palla@valuelabs.net 1440 T Completed Completed
User Security Details
Security Group Name Transaction Id Action Process Phase Process Status
PDE - All Users 1441 Validating Errored (parent) F

Is it a bug in import report? How come we need to run twice to add new user into PPM
and assign security group to that user?
Thanks
Jim Esler
Honored Contributor

Re: Import Users : User Error:INVALID_USER

When you are adding new users, the security groups are listed in the Security Groups field on the request. Existing users can be updated with changes to their security group affiliations by specifying the ADD/DROP security group action and placing appropriate entries in the knta_user_security_int table. This is described in the 6.0 reports manual. I have not checked the 7.x manuals to see what they say.
Long Xuong
Occasional Contributor

Re: Import Users : User Error:INVALID_USER

Hi Jim
When running import user report, I selected
"Add Security Groups" from the "User security group action" drop down box.
and I checked in the KNTA_USER_SEC_INT package and see that we got error message id = 10 when missing column dest_user_id.
I checked knta_user_security_int, that user has valid value for dest_user_id field.

Thanks a lot for your help..
Jim Esler
Honored Contributor

Re: Import Users : User Error:INVALID_USER

The knta_user_security_int table is only supposed to be used when the ADD/DROP option is selected. When this table is used with the ADD or the DROP options, PPM gets very confused. At least that is our experience.
Long Xuong
Occasional Contributor

Re: Import Users : User Error:INVALID_USER

Hi Jim
Really.?? That's good to know. Thank a lot for your information. :)
John2000
Acclaimed Contributor

Re: Import Users : User Error:INVALID_USER

Can you tell me about the import users in detail.
//Add this to "OnDomLoad" event