Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

ITG Windows service starts and stops immediatelly

Highlighted
Alexei Malinovs
Regular Collector

ITG Windows service starts and stops immediatelly

Dear Community,

We are prepearing for upgrade PPM6.0 to 7.1 and now we have a problem.

We have installed new HW server and on it we:
1. Installed Oracle
2. Cloned Mercury 6.0 app
3. Imported DB

Problem:
When we start Mercury service it starts and then immediatelly stops telling that it has nothing to do.

Any ideas what does it mean and how to keep it runnig?

9 REPLIES
Sascha Mohr
Esteemed Contributor

Re: ITG Windows service starts and stops immediatelly

What does the server.log say? Can you post it?
pradeep k.r.
Super Collector

Re: ITG Windows service starts and stops immediatelly

Hi Alexei,

As suggested, please post the server logs or get the verbose o/p for the kstart.sh script running the command "./start.sh -verbose" using cygwin UI.


Thanks,
Pradeep
Alexei Malinovs
Regular Collector

Re: ITG Windows service starts and stops immediatelly

Sascha, pradeep,
Thank you for your help!

Log file attached.
There is one thoing I didn';t mention. On the PROD environment we have Documentum installed. But when we cloned the environment we didn't want documentum anymore and didn't executed cloning steps for documentum.

Could this be the reason why server doesn't start?
Could you look into log files and give your advice what is wrong?
Alexei Malinovs
Regular Collector

Re: ITG Windows service starts and stops immediatelly

Oh, please ignore log file attached to previous e-mail. We install ITG under Windows and log file was generated bykStart.sh that should not be run under windows.

Now, when we try to start Mercury from Windows services it states:

"The Mercury ITG PROD service on Local Computer started and then stopped. some services stop automatically if they have no work to do."

Q1: When we check log files directory no new logs are created. We tried to modify server.conf file to increase log level and this didn't work either. No logs created. Any ideas why?

Q2: also can the problem be that we do not install Documentum to cloned environment even though we clonned Mercury from the server with Documentum installed? If yes is there a way to disable documentum and avoid installing it in cloned environment?
Alexei Malinovs
Regular Collector

Re: ITG Windows service starts and stops immediatelly

Or may be the log file is valid if it is allowd to use kStart.sh from Cygwin in windows? documentation states this this command is only for Unix.

So, look at it please :)
Cesar Roque
Regular Collector

Re: ITG Windows service starts and stops immediatelly

Hi Alexei,

I have no experience with documentum, but as far as I know you have to clone the documentum too.

At your log files I saw that error:

java.net.BindException: Address already in use: JVM_Bind

That means that ports you are using for your application are already opened for another app, use the nestat -na command to check your available ports, then change then at the server.conf file and run the kupdatehtml command. Afer that maybe you can start your app, I don't know If it can start even you are getting documetum related errors.

Regards

pdhawan
Super Collector

Re: ITG Windows service starts and stops immediatelly

Hi,

Were you able to fix this one? I guess we can remove the integration between PPM and DOCUMENTUM.

Thanks
Alexei Malinovs
Regular Collector

Re: ITG Windows service starts and stops immediatelly

Hello,

Yes, we were able to fix this. It took 2 steps:

1. We disabled Documentum in configuration files of cloned environment. So, we didn't need to instal it.

2. We had ~500 users activated in original environment but in cloned environment we had only 4 users license file. So, we disabled all users except 4 in KNTA_USERS table.

After these 2 steps cloned environment started without any problems :)
pawan_infy1
Acclaimed Contributor

Re: ITG Windows service starts and stops immediatelly

Hi, How did you disabl the documentum ie, delinking documentum and PPM...
What happens to documents which are already attached ?
//Add this to "OnDomLoad" event