Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

IIS 7.0 - 403 forbidden error

SOLVED
Go to solution
Highlighted
LucciB
Occasional Advisor

IIS 7.0 - 403 forbidden error

Hi

 

I found a guide on a discussion thread here about how to configure IIS 7.0.

It was straight forward and easy to follow but I seem to be having problems with permissions when trying to access the site.

 

I receive a 403 - Forbidden: Access is denied.

When I brwose the site from within IIS it suggests enabling directory browsing, which doesnt seem to help.

It also suggests setting a default document.

 

Am I on the right track here or have I forgotten a permission step somewhere?

 

Regards

Luciano

2 REPLIES
dirkf
Honored Contributor
Solution

Re: IIS 7.0 - 403 forbidden error

Hi Lucci,

 

Please make sure that the IIS port is listening on the same port as configured in the server.conf in BASE_URL-parameter and that this port is not only open but also different to the one set for EXTERNAL_WEB_PORT configured in the same file and also in the workers.properties-file.

 

 

Also check the ISAPI:

1. Start | Setting | Control Panel | Administrator tools | IIS Manager
2. Click on the “(local computer)” | Web Services Extension
3. Check to see “All Unknown ISAPI Extensions” has “Allowed” status. If not, the redirector isapi will not execute and as a result, requests will not get to ITG server.

 

If all fails, please let's have more information about the configuration of the IIS-server and we'll try to assist further.

 

Best regards,

Dirk

LucciB
Occasional Advisor

Re: IIS 7.0 - 403 forbidden error

Thanks Dirk

 

I couldn't find the ("local computer") | Web services extention option.

I can only assume you meant the ISAPI and CGI Restrictions. For that both "Allow unspecified ISAPI modules" and "Allow unspecified CGI modules" are enabled.

 

We did find however that when we use the entire URL for PPM "*/itg/dashboard/app/portal/PageView.jsp" IIS served the page and browsing is fine.

 

We thought about using a HTTP redirect but found that using it made the page load a lot longer.

 

Regards

Luciano

//Add this to "OnDomLoad" event