Project and Portfolio Management Practitioners Forum
cancel

How to limit the number of records in portlet

Highlighted
James++
Super Contributor.

How to limit the number of records in portlet

Hi All,

Recently I got stuck in one of the issues regarding the Portlet record limit.

In this I need to limit the number of rows in the portlet. In order to do the same I perform below steps.

1. Set the PORTLET_MAX_ ROWS_RETURNED PORTLET_MAX_ROWS_RETURNED parameter to 300 in server.conf file
2. Then I stop the server and run kUpdateHtml.sh
3. Finally I started the server.

But still in some of the portlet the number of records are exceeding 300. I have also tried to set the limit in Portlet configuration but no success. Is that I am missing any thing.

Please let me know, how to limit the number of records in portlet in HP PPM version 7.5.

Thanks
Utkarsh
4 REPLIES
Volker Schoettn
Honored Contributor.

Re: How to limit the number of records in portlet

Hi,

the PORTLET_MAX_ROWS_RETURNED is a hard limit for all portlets. This limit is implemented for performance reasons.

If the portlet result exceeds this number you must configure some filter and advice the users to use it or extend the parameter value in server.conf.

However, first check how mutch records the portlet statement will find.
Decide if it is feasible (for performance) to extend the PORTLET_MAX_ROWS_RETURNED
Or advice the users to use the search functionallity instead of portlets.

Regards
Volker
Catherine Curti
Respected Contributor.

Re: How to limit the number of records in portlet

Sounds like you have the opposite problem as the norm. You have too many rows despite the config setting. I'm not sure what the answer is but if you figure out how its happening I'd love to know. I've got a special portlet where I'd like to override the config setting.

The ones exceeding 300 - are they custom?
Jim Esler
Acclaimed Contributor.

Re: How to limit the number of records in portlet

I believe the row limit is bypassed if the data source includes a GROUP BY clause.
Mahen M
Acclaimed Contributor.

Re: How to limit the number of records in portlet

Jim is correct, Even the commented Group by clause could override PORTLET_MAX_ ROWS_RETURNED, Please add another filter and introduce the clause 'AND ROWNUM >=300' and make this filter hidden, It will solve your issue.

Regards,
Mahendran M