Project and Portfolio Management Practitioners Forum
cancel

How to limit the number of records in portlet

SOLVED
Go to solution
Highlighted
Utkarsh_Mishra
Acclaimed Contributor.

How to limit the number of records in portlet

Hi All,

 

Recently I got stuck in one of the issues regarding the Portlet record limit. 

 

In this I need to limit the  number of rows in the portlet. In order to do the same I perform below steps.

 

 

  1. Set the 
    PORTLET_MAX_
    ROWS_RETURNED
    PORTLET_MAX_ROWS_RETURNED parameter to 300 in server.conf file
  2. Then I stop the server and run kUpdateHtml.sh
  3. Finally I started the server.
But still in some of the portlet the number of records are exceeding 300. I have also tried to set the limit in Portlet configuration but no success. Is that I am missing any thing.
Please let me know, how to limit the number of records in portlet in HP PPM version 7.5.
Thanks
Utkarsh

 

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
5 REPLIES
sebastianrm
Trusted Contributor.

Re: How to limit the number of records in portlet

Hi, be sure u r using a full format.

 

com.kintana.core.server.PORTLET_MAX_ROWS_RETURNED=200

 

Then check for Server Configuration Report to see if PPM is showing correct values.

 

Let me know,

 

 

S

Pawan Wattamwar
Contributor.

Re: How to limit the number of records in portlet

You Can control it through SQL in datasource. Like this

 

select * from <table_name> where rownum < 200

 

Utkarsh_Mishra
Acclaimed Contributor.
Solution

Re: How to limit the number of records in portlet

Hi All,

 

What I have noticed that for the portlets, whose datasource query is having the outerjoins or not having the group by condition; in these portlets the PORTLET_MAX_ROWS_RETURNED parameter is not working.

 

I have tested this in PPM v 7.1. May be this is the tool limitation.

 

To avoid such scenario, include any group by condition and avoid usage of outerjoin.

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
vonderhe
Regular Contributor.

Re: How to limit the number of records in portlet

Hi,

 

if you use a own datasource (even better) make sure you sort the entries befor adding rownum. So it's better to ...

 

 

select a,b,c from

(select ... order by)

and rownum < 200

 

 

Cat_2
Super Contributor.

Re: How to limit the number of records in portlet

If you use...

 

select a,b,c from

(select ... order by)

and rownum < 200

 

my understanding is that if you are trying to group rows then return results - this won't necessarily work. You have to pull all results, group them as needed, then pull the 200 or whatever number from that new grouped dataset. If I just pull the top 200, it may pull 200 but it will only group the 200 I pull which might mean I'm leaving the correct data out. This has been my experience at least.