Project and Portfolio Management Practitioners Forum
cancel

How to enable webservices in 9.2 version

SOLVED
Go to solution
Highlighted
ShravanK
Super Contributor.

How to enable webservices in 9.2 version

Hi,

 

We are using PPM 9.2 version in our dev environment.

We are trying to open below url

https://<server>/itg/ppmservices/DemandService?wsdl


We are getting below error eventhough we have enabled web services


"Web services are not enabled for this server. Please contact your administrator"


we have already set the parameter "com.kintana.core.server.ENABLE_WEB_SERVICES=TRUE"


Can anyone tell me what could be the problem.


Is there any impact for the normal webserivce URL if we enable restful web service in same environment i.e setting parameter /rest=com.kintana.core.web.servlet.AllAccessURLSecurity


Best Regards,
Shravan

4 REPLIES
ManojKumarNS
Trusted Contributor.

Re: How to enable webservices in 9.2 version

Hi Shravan,

 

1.please check wheteher you have set the EXTERNAL_WEB_PORT parameter on the PPM Server if you are using an external web server.

2. Also please check you have specified workers.properties correctly.

 

The connection between the PPM server and the webserver is some where missing(thats why you are getting the error 'Web services are not enabled for this server. Please contact your administrator' ) so i suggest you to check the port features!

 

Thanks

Manoj Kumar N S

 

ShravanK
Super Contributor.

Re: How to enable webservices in 9.2 version

Hi Manoj,

 

Thank you for the response..

 

We have crossed checked those.. those seems to be correct. But interesting thing is when we view this parameter from front end admin console, the setting is showing as false where as through server it is showing as true.

 

Why it is behaving like this.. where is the problem..

 

Best Regards,

Shravan

 

 

ShravanK
Super Contributor.
Solution

Re: How to enable webservices in 9.2 version

Unfortunately, there were 2 entries with same name one with false and other with true. We have removed false one and now we are able to open.

ManojKumarNS
Trusted Contributor.

Re: How to enable webservices in 9.2 version

oh.. Is that all fine?