Project and Portfolio Management Practitioners Forum
cancel

How to change Time Period search Validation

Highlighted
vamsee_1
Respected Contributor.

How to change Time Period search Validation

Hi,
could anyone tell me how do we change Time Period Validation in Time Approver Portlet(Which can be seen by Time Sheet Approver) as it shows only a few past time periods.
9 REPLIES
Erik Cole_1
Outstanding Contributor.

Re: How to change Time Period search Validation

Sure. Set com.kintana.core.server.TMG_PAST_PERIODS_TO_ALLOW in server.conf to whatever value you require.
vamsee_1
Respected Contributor.

Re: How to change Time Period search Validation

Hi,
I could not see the com.kintana.core.server.TMG_PAST_PERIODS_TO_ALLOW in server.conf in server config file. Is their any other way of doing this.
vamsee_1
Respected Contributor.

Re: How to change Time Period search Validation

Hi,
I could not see the com.kintana.core.server.TMG_PAST_PERIODS_TO_ALLOW in server.conf in server config file, i think thats a default one set in ITG. Is their any other way of doing this.
Erik Cole_1
Outstanding Contributor.

Re: How to change Time Period search Validation

It's one of the settings that isn't in the server.conf file unless you put it there to customize it. Otherwise, it's just defaulted to a value of 10.
cbeyond1
New Member.

Re: How to change Time Period search Validation

If you check the server configuration report from :
Workbench > Sys Admin > Server Tools > Admin Tools > Server Configuration Report.

You would see this parameter:
com.kintana.core.server.TMG_PAST_PERIODS_TO_ALLOW 10

This is the default server config setting. YZou can change it by setting this parameter in the server.conf file.


vamsee_1
Respected Contributor.

Re: How to change Time Period search Validation

Hi,
Thanks for fast response.
I am still unable to get past Time Periods
even after adding the command in Server config file. And even i ran kUpdateHtml.sh after adding. Is their any limitation on adding Time Periods like 50 or 100. kindly help us.
Thanks in advance.
Erik Cole_1
Outstanding Contributor.

Re: How to change Time Period search Validation

Couple more things then:

- The line you put in server.conf looks like:

com.kintana.core.server.TMG_PAST_PERIODS_TO_ALLOW=80

with the equal sign, correct? We are using 80 no problem here while we catch up on some old data entry.

- What PPM version?

- What specific portlet are you looking at? In my (7.1) instance both the Approve Time Sheets portlet and Approve Time from TM menu link have the "Previous Time Periods to Show" as a numeric text box...?

- Do the time periods show up in the validation when you try to create a new time sheet?
vamsee_1
Respected Contributor.

Re: How to change Time Period search Validation

Hi Erik,

Thank you very much. i got it.
Regards,
Vamsee.
vamsee_1
Respected Contributor.

Re: How to change Time Period search Validation

Thank You Erik.