Project and Portfolio Management Practitioners Forum
cancel

Having Problem while execution of a clear command in PPM 7.1

SOLVED
Go to solution
Highlighted
sevcan
Super Contributor.

Having Problem while execution of a clear command in PPM 7.1

Hi, 

 

I am getting this error "Attachment File could not be downloaded. The File: REQ_113044/REQ_113044_BID_2964023.html no longer exist in the server. Please contact your HP Project and Portfolio Management system administrator. (KNTA-10697)" in the execution of a command. I attached a screenshot of the command so you can find the details.

 

Thank you,

This is urgent. 

20 REPLIES
AlexSavencu
Acclaimed Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

Hi,

 

can you also post a screenshot of the error? that attachment is the execution log for the automatic steps execution within the specific request.

 

cheers

alex


--remember to kudos people who helped solve your problem
sevcan
Super Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

Hi, 

 

The error says "Attachment File could not be downloaded. The File: REQ_113044/REQ_113044_BID_2964023.html no longer exist in the server. Please contact your HP Project and Portfolio Management system administrator. (KNTA-10697)" this. It does not give any other details.

AlexSavencu
Acclaimed Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

Hi,

 

does the step fail? where is your workflow routed? what is displayed in the graphical workflow view for the transition from this step?

have you tried locating the file in the server FS?

does this happen for all execution steps or only this one?

try changing the command code to ksc_store REQ.P.TOKEN = ””

 

let us know how it goes.

 

cheers

alex


--remember to kudos people who helped solve your problem
sevcan
Super Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

Hi,

 

It does not have a fail. It only has success. It is routed to another execution. I tried opening the graphical view but it did not open it.  I dont have direct access to the server.  It happen for the other ones too. 

 

Regards,

Sevcan

AlexSavencu
Acclaimed Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

Hi,

 

in this case I do not think you have critical problem, aka not preventing the functioning of your PPM instance.

 

I would suggest for you to get in contact with the system administrator for the server machine and investigate the reason for the log file not generating - there could be any number of reasons: free space issues, or someone might have deleted the folder for the specific request.

 

cheers

alex


--remember to kudos people who helped solve your problem
sevcan
Super Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

Ok, it is not critical problem but it it is an important problem. The end user have to override this execution after getting this error and it is not nice.  I will try to get contact with the system administration but do you have any other solutions?

 

Regards,

Sevcan

AlexSavencu
Acclaimed Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

hi,

 

unfortunately there is no other solution. This issue relies in the server administration area.

 

I know some PPM system administrator who periodically clean up the PPM_HOME/logs directory - some of them do it just for fun. Check with your sysadmins if this is the case.

 

cheers

alex


--remember to kudos people who helped solve your problem
sevcan
Super Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

OK, then I will ask system administration clean of the PPM_HOME/logs directory. But, I dont think it will solve it.

 

Still thank you,

Regards, 

Sevcan

AlexSavencu
Acclaimed Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

Hi,

 

:) do not ask them to delete clean the directory.

 

Instead, ask them if they have done such a cleanup and if the directory for the specific request is still there.

 

Also, if this error occurs for ALL automatic steps, ask them if the user which runs the PPM server has the appropriate permissions to write to the directory. Usually it goes much easier if you explain the sysadmin the situation.

 

All the above will definitely not solve the problem for existing request(s), but will prevent the problem from reoccuring for new requests.

 

cheers

alex


--remember to kudos people who helped solve your problem
Jim Esler
Acclaimed Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

As noted in earlier replies, this can be caused by file system problems in the logs directory. The two common reasons are file system full and (on UNIX hosted file systems) the limit on subdirectories in a directory.  If either of these is causing the problem, it would affect all request types and execution steps, not just a specific one.

 

I have also seen this situation when the execution step has started but the directory or file has not yet been created. Check the Execution Dispatcher Manager report in the Server Tools workbench to see if there are any issues with executions.

 

Are you running the latest 7.1 SP? Check the final Release Notes to see if this is related to any known issues.

sevcan
Super Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

Hi,

 

I ask them to clean the file system from old files.  It was better. I mean some of the execution is still doing it. But, not all of them. I will check with the report and sp.

 

Regards,

 

 

sevcan
Super Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

Hi,

 

Now, I started to get this error in the execution log. 

 

 

AlexSavencu
Acclaimed Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

Hi,

 

the screenshot does not report an error - it only shows that the source token is empty.

 

cheers

alex


--remember to kudos people who helped solve your problem
sevcan
Super Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

The execution does not finish. I have to override it to finish. That's why I thought this is an error. Then,what should I do? Because it is not a nice thing for my customer to override an execution which is supposed to run automaticcally.

 

Regards,

AlexSavencu
Acclaimed Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

are there any other commands in this step? I am asking this because the ksc_store command finishes...

 

On the other hand, you can have another approach:

- set up a dummy automatic step that will always return success

- set up a dummy status for this automatic step

- in status dependencies, set the required field to "Clear".

 

btw, this approach has less load on the system....

 

cheers

alex


--remember to kudos people who helped solve your problem
sevcan
Super Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

Hey,

 

There is not any other command on this step.

The approach you have been suggesting may be work on this one. But, there are other commands which copy some tokens to some fields. Steeting Clear in the status dependency wont be helping in those executions.

 

Thanks,

Sevcan

Utkarsh_Mishra
Acclaimed Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

Hi Sevcan,

 

Have you created this Execution step by making a copy of any exisitng execution step?

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
sevcan
Super Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

Hı,

 

I am not the one who created this executions. I am doing changes on top of the existing workflows and requst types. So,I dont havbe any ideas about if the executions are copied from existing one. 

 

Thanks,

 

AlexSavencu
Acclaimed Contributor.
Solution

Re: Having Problem while execution of a clear command in PPM 7.1

sevcan,

 

my approach suggests to REPLACE the execution steps used to clear fields with the ”clear” button in Status Dependencies.

 

moreover, I still think your problem relies on the server filesystem and not in the step(s) configuration.

 

cheers

alex


--remember to kudos people who helped solve your problem
sevcan
Super Contributor.

Re: Having Problem while execution of a clear command in PPM 7.1

Hi Alex,

 

I talked with the guy who takes care of the filsystem and it appeared that there is a entegration which throws lots of log in to the filesystem and which causes my problem. I think the only ways is cleaning those logs periodically. Thank you very much for your help with my problem. 

 

Best Regards,

Sevcan