Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Getting error while saving any request type in PPM 9.20

Highlighted
ShravanK
Regular Collector

Getting error while saving any request type in PPM 9.20

Hi,

 

We are getting below error while saving any request type in PPM 9.20 version.

 

Error:

 

ORA-04091: table MITG.KCRT_REQUEST_TYPES_NLS is mutating, trigger/function may not see it
ORA-06512: at "MITG.KCRT_REQ_RHT_AUDIT_31064_1", line 21
ORA-04088: error during execution of trigger 'MITG.KCRT_REQ_RHT_AUDIT_31064_1'
ORA-06512: at "MITG.KCRT_REQ_TYPES_NLS_SEARCH_TR", line 4
ORA-04088: error during execution of trigger 'MITG.KCRT_REQ_TYPES_NLS_SEARCH_TR'
ORA-06512: at "MITG.KCRT_REQUEST_TYPES_TRIG", line 164
ORA-04088: error during execution of trigger 'MITG.KCRT_REQUEST_TYPES_TRIG' {KCRT_REQUEST_TYPES_TH-400}
GUID=010B3F45-8EF5-E7B1-65D0-E62591DEAF1

 

Can any one please tell me what could be the problem?

 

Best Regards,

Shravan

2 REPLIES
knsub
Member

Re: Getting error while saving any request type in PPM 9.20

 

Hello Shravan,

 

The reason for this error is the presence of the following triggers being active:

KCRT_REQ_TYPES_NLS_SEARCH_TR
KCRT_REQ_TYPES_LOC_SEARCH_TR
PM_PROJECT_TYPES_SEARCH_TR

 

Disable the listed triggers and the error will no longer occur:

alter trigger KCRT_REQ_TYPES_NLS_SEARCH_TR disable;
alter TRIGGER KCRT_REQ_TYPES_LOC_SEARCH_TR disable;
alter TRIGGER PM_PROJECT_TYPES_SEARCH_TR disable;

 

The said triggers are related to a fuzzy search feature, which is not yet added to PPM, but is previewed for a future inclusion. Disabling them will not affect PPM functionality in any way.

 

Hope this helps.

 

Thanks,

Subash

 

Etienne_Canaud
HPE Expert

Re: Getting error while saving any request type in PPM 9.20

Note that these triggers will be automatically removed when you install PPM 9.21, which has been recently released. 

 

You might want to at least go through the release notes to know of the issues that have been fixed, and evaluate the relevence of an upgrade from 9.20 to 9.21.

 

Kind Regards,

Etienne.

//Add this to "OnDomLoad" event