Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

GUID Error w/ Request List Portlet when Including "Link" type field

Highlighted
pepdwill
Senior Member

GUID Error w/ Request List Portlet when Including "Link" type field

I was wondering if someone can confirm whether this a known bug...

 

We have a request type that includes a field that is using the Link validation.  When performing an Advanced Request Search and setting it to display the Link field, there are no issues. When trying to show the field using a standard OOTB Request List portlet, a GUID error is returned and the portlet is not displayable.

 

We've confirmed that the Link field is causing the error, but I have no idea why.

 

- Is this a known limitation/bug that has already been logged with HP?

- Are others able to reproduce this issue?

- Is there a workaround?

 

Any additional information anyone can provide would be helpful.

 

 

Thanks!

 

Danny

 

 

 

8 REPLIES
pepdwill
Senior Member

Re: GUID Error w/ Request List Portlet when Including "Link" type field

Here is the error detail from the server log:

 

An unknown error has occurred. For more information, please contact your PPM administrator and provide the following GUID number:
GUID=4B500DD8-27C2-263C-A8E8-9D23956AEF51
nested detail:ORA-00972: identifier is too long

 

 

 

mike_se
HPE Expert

Re: GUID Error w/ Request List Portlet when Including "Link" type field

Hi Danny,

 

When you get the GUID, search the serverLog.txt file on the node that the User is logged in to.

 

Hopefully the stack dump can provide details as to why the issue is happening.

 

I found one Known Problem when the Attachment Field has a name longer than 18 characters. In the DEV environment, try shortening the Name/Token to see if this helps.

 

-Mike

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
pepdwill
Senior Member

Re: GUID Error w/ Request List Portlet when Including "Link" type field

Hey Mike... the error from the server log was pasted above.

mike_se
HPE Expert

Re: GUID Error w/ Request List Portlet when Including "Link" type field

You must have posted the error when I was typing.

 

"unknown error" is seen in that long Token issue.

 

Hopefully shortening will help your Request List Portlet.

 

-Mike

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
mike_se
HPE Expert

Re: GUID Error w/ Request List Portlet when Including "Link" type field

Oh nope, it said an hour ago. Sorry about that. Must have forgot to scroll down more.

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
pepdwill
Senior Member

Re: GUID Error w/ Request List Portlet when Including "Link" type field

So just to clarify what I think you're saying... our token name for the field causing the issue might be too long?   I will check this and report back to you...

mike_se
HPE Expert

Re: GUID Error w/ Request List Portlet when Including "Link" type field

That is correct.

 

Defect is QCCR1L42139 and looks to still be open.

 

"ORA-00972: identifier is too long" error in Request List Portlet when using an Attachment field with a token name that's longer than 18 characters"

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
pepdwill
Senior Member

Re: GUID Error w/ Request List Portlet when Including "Link" type field

Ahh!

 

Shortening the token name fixed it.

 

Thanks Mike!

//Add this to "OnDomLoad" event