Project and Portfolio Management Practitioners Forum

FM Websrvice error

Trusted Contributor.

FM Websrvice error

Hi ,

I am getting the beelow mentioned error while updating the budget through FM webservice.Please help me

Missing required element {}accessList

Honored Contributor.

Re: FM Websrvice error

Hi Ashu,


I was getting similar responses when the axis2.xml file was not configured as marked in the web services developers guide.


In order to use basic authentication, you need to set up the axis2.xml config file so that it knows what authentication its going to use, this change is:



In a scenario where it is not convenient to use WS-Security, it is possible to configure PPM Center to accept user credentials passed by using HTTP basic authentication headers.


1. Open the $PPM_HOME/server/kintana/deploy/itg.war/WEB-INF/conf/axis2.xml file.


2. Locate “InflowBasicAuth” section.


3. Change the value of “Enforced” to true:

<parameter name="InflowSecurity">
<items>UsernameToken Timestamp Encrypt</items>
<parameter name="InFlowBasicAuth">


4. Save and close the axis2.xml file



The error message:


Missing required element {}accessList

Points to this.


Once that was done, any error messages I had disappeared, and I was able to update requests (tested for reference) and financial summaries without any issues.

I have also created a whole forum post on how to configure the web services toolkit of PPM in the Customer Support forum (active SAID required):


I hope this helps.


Best regards,



HPE Support

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
New Member.

Re: FM Websrvice error

Many Thanks,

As you advised i saw axis2.xml config file and it is already set as you advised but still there is same error occuring.If you dont mind could you please send me your code for my refrance or any idea to resolve id is

Trusted Contributor.

Re: FM Websrvice error


Now I am getting

Missing required element {}financialSummary


What you requested it was already set in conf parameter.Still this problem occuring