Project and Portfolio Management Practitioners Forum
cancel

Excel Reporting using PPM Datasource - Report Filters not working (HP PPM 9.3X)

SOLVED
Go to solution
Highlighted
SIMI SIVARAJAN
Trusted Contributor.

Excel Reporting using PPM Datasource - Report Filters not working (HP PPM 9.3X)

I am trying to run Excel Reports using the new excel reporting functionality using PPM Datatsource  on HP PPM 9.32

 I was able to successfully generate data from the Datasource using the Excel Reporting functionality. 

However I am not able to fetch data based on the filters provided in the Datasource. My report fetches resource effort based on the start date and end date provided by the user. Although it works fine in a portlet but not when i try to generate the data using the new Excel Reporting functionality. 

I am using the following placeholder in the xls template to get data.

<jt:forEach items="${datasources.get('Monthly Resourcewise Effort').addFilter('Start Date', START_DATE).addFilter('End Date', END_DATE).addFilter('Resource Name', USER_ID).getData()}"

Where:

Monthly Resourcewise Effort - Datasource Name

Start Date - Filter Name  START_DATE - filter token

End Date - Filter Name  END_DATE - filter token

Resource Name - Filter Name  USER_ID - filter token

 Same filters i have used in the report type as well along with the same token.

 

 

2 REPLIES
Etienne_Canaud
Micro Focus Expert
Solution

Re: Excel Reporting using PPM Datasource - Report Filters not working (HP PPM 9.3X)

Hi,

The syntax of "addFilter()" is to pass first first the token name as a string, and then the filter value. You should never pass the filter name.

You'll usually get the values from a report type field; let's suppose that that this report field token is P_FIELD_TOKEN. So you should call it this way:

${datasources.get('Monthly Resourcewise Effort').addFilter('FILTER_TOKEN_NAME', P_FIELD_TOKEN).addFilter('FILTER_TOKEN_NAME_2', _P_FIELD_TOKEN_2).getData()}

As you can see, it's a bit confusing as the first parameter has quotes (you're telling which filter you're setting the value of), and the second parameter has no quote (as you're referring to a variable that's passed to the report template when report is submitted).

Thanks,

Etienne.

SIMI SIVARAJAN
Trusted Contributor.

Re: Excel Reporting using PPM Datasource - Report Filters not working (HP PPM 9.3X)

Thanks Etienne. I tried what you have mentioned in your reply and it worked.