The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Error while running the report

SOLVED
Go to solution
Highlighted
Varun_PPM
Super Collector

Error while running the report

We have recently upgraded PPM instance to version 9.1.

 

After upgrade we encounter below error while running the reports

 

Error retrieving environment information. Text doesn't appear to be encoded or there is an encryption key mismatch.

This perticular report is OOTB package detail report.

 

Regards,

Varun

14 REPLIES
Celil
Esteemed Contributor

Re: Error while running the report

Hi,

 

Is there log details?

 

Celil

Celil

IT Governance Professional
& PPM Solution Architect
Varun_PPM
Super Collector

Re: Error while running the report

Below is log message in report log

 

CL Local Exec

 

Source Command:Run Report D:/oracle/product/10.2.0/client_1/bin/sqlplus.exe PPMADMIN/#!#*****#!#@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=usphl09.s.com)(PORT=1625)))(CONNECT_DATA=(SERVICE_NAME=DEVD))) @./scripts/kdlvrpt_pkg_detail 'D:\PPM\reports\' 'rep_46683' '34375' '34375' '' '' '' '' '' '' '' '1' 'N' 'Y' 'N' 'N' 'N' 'Y' 'N' Error retrieving environment information. Text doesn't appear to be encoded or there is an encryption key mismatch

 

Additional meesage from server log

 

ERROR :CommandRunner for com.kintana.core.server.execution.CLLocalExecCommand Batch ID: 370913:com.kintana.core.executions.commands.localExec:2011/08/23-04:59:46.773 EDT: Unexpected exception occurred running ksc_local_exec:
java.lang.RuntimeException: Text doesn't appear to be encoded or there is an encryption key mismatch.
    at com.kintana.sc.security.ElGamalAlgorithm.decode(ElGamalAlgorithm.java:371)
    at com.kintana.sc.security.ElGamalAlgorithm.decrypt2(ElGamalAlgorithm.java:396)
    at com.kintana.core.util.PasswordManager.decryptElGamal(PasswordManager.java:422)
    at com.kintana.core.util.PasswordManager.decrypt(PasswordManager.java:127)
    at com.kintana.core.util.PasswordManager.decrypt(PasswordManager.java:143)
    at com.kintana.core.util.FileUtils.getLocalhost(FileUtils.java:432)
    at com.kintana.core.server.execution.CLLocalExecCommand.execute(CLLocalExecCommand.java:450)
    at com.kintana.core.server.execution.CommandRunner.run(CommandRunner.java:106)
    at java.lang.Thread.run(Thread.java:619)

Celil
Esteemed Contributor

Re: Error while running the report

Hi Varun,

Please check public_key.txt and private.txt file in <PPM Home>/security folder. There are encryption algorithm name at first line of these files. Are these same?

Celil
Celil

IT Governance Professional
& PPM Solution Architect
Varun_PPM
Super Collector

Re: Error while running the report

Hi Celil,

 

Both are same.Not getting this error at any other place but just when i run this report this issue appears.

 

I found another solution in this blog but its not working.is it valid? Please find below.

 

http://mercuryitg.blogspot.com/2006_05_01_archive.html

 

If you change the database password, there are two places that need to be encrypted

1) server.conf
2) knta_users table - password field server.conf relates to connecting to the itg server ie: starting up ITG knta_users password field relates to being able to login as a user. It is necessary to update this field eg: update knta_users set password = 'BQq*2l*}Mrb)u+W1myD4@^R1=+r6lPvl1<*Vnt+J/Wu=B:w(}pr:B}z)Q(-/ZIR2>V6R+A^0$FTs4IX46?:'

It sets all users with the same password. If you don't do this, you get this error in the servertext.log: Text doesn't appear to be encoded or there is an encryption key mismatch.

If there is an "&" in this string, sqlplus will think that it is a parameter, so the way to handle this is to do:
set scan off

 

 

Regards,

Vibhor

Celil
Esteemed Contributor

Re: Error while running the report

Hi Vibhor,

It's too old and not for your issue. Could you please check environment settings in workbench/Environments especially KINTANA_SERVER. First of all click "check" to learn what is running what is not. (If all are running do not continue) Then please reenter server, client, database passwords and click "check" to ensure all settings running.

Celil
Celil

IT Governance Professional
& PPM Solution Architect
Utkarsh_Mishra
Honored Contributor

Re: Error while running the report

Can you please let me know this server.conf paramter value..

 

com.kintana.core.server.SQLPLUS_VERSION

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
Varun_PPM
Super Collector

Re: Error while running the report

Hi Utkarsh,

 

We dont have this parameter in our Server conf file.

 

I changed its value to 102010. But no change in error message appearing in report.

 

Regards,

Utkarsh_Mishra
Honored Contributor

Re: Error while running the report

If this parameter is not there then add this

 

com.kintana.core.server.SQLPLUS_VERSION=10.2.0.1

 

(put your DB version)...

 

After this run kUpdateHtml.sh and then start the server...

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
Varun_PPM
Super Collector

Re: Error while running the report

Hi

 

i have added the com.kintana.core.server.SQLPLUS_VERSION=10.2.0.1 and ran the kUpdateHtml.sh

 

But no change in results.

 

i tried to run report command on PPM server command promopt with actual password its working fine there.

 

D:/oracle/product/10.2.0/client_1/bin/sqlplus.exe PPMADMIN/password@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=uhdb08.s.s.com)(PORT=1625)))(CONNECT_DATA=(SERVICE_NAME=ppmd))) @./scripts/kdlvrpt_pkg_detail 'D:\PPM\reports\' 'rep_46837' '30009' '30009' '' '' '' '' '' '' '' '1' 'N' 'Y' 'N' 'N' 'N' 'Y' 'N' 

 

PL/SQL procedure successfully completed.

 

It looks like decryption issue.Any idea which command PPM use to decrypt password while running the PPM reports

Utkarsh_Mishra
Honored Contributor

Re: Error while running the report

If this is not you production environment then run this script

 

kKeygen.sh

 

 

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
Varun_PPM
Super Collector

Re: Error while running the report

Hi After running the kKeygen.sh.The above error is gone.I am getting below error message.

Error retrieving environment information.
bad UTF

any input on this..
Utkarsh_Mishra
Honored Contributor

Re: Error while running the report

Open the KINTANA_SERVER environment and change the "Stream Encoding" to "US-ASCII"

 


Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
Varun_PPM
Super Collector
Solution

Re: Error while running the report

Thanks A lot for driving in right direction.

 

Report is running fine now just updated the KNTA_SERVER environment as well as added the I18N_REPORTS_
ENCODING patameter value in server.conf.

 

Cheers.

KaranMalhotra
Occasional Contributor

Re: Error while running the report

I have the same "bad UTF" error while running some reports.

 

I have:

 

- changed the Stream Encoding to UTF-8 / US-ASCII for both the server and client areas;

 

- 'checked' the environment record - success;

 

- updated the server.conf file with I18N parameters with both UTF-8 and US-ASCII values.

 

Restarted the PPMc services after running kUpdateHtml - still the issue persists.

 

What could be the problem at this stage. I am getting no where with this.

 

Any and all assistance will be greatly appreciated.

 

[EDIT] This environment was recently updated from 9.14 to 9.22

//Add this to "OnDomLoad" event