Project and Portfolio Management Practitioners Forum
cancel

Error running ksupport.sh

Highlighted
Abdullah Rafiq
Respected Contributor.

Error running ksupport.sh

I tried to run the ksupport.sh program on the client machine and got the following error message - do you know what the problem is? It say something about the run file.

sh ksupport.sh
cygwin warning:
MS-DOS style path detected: c:/
Preferred POSIX equivalent is: /cygdrive/c
CYGWIN environment variable option "nodosfilewarning" turns off this war
Consult the user's guide for more details about POSIX paths:
http://cygwin.com/cygwin-ug-net/using.html#using-pathnames
JAVA_HOME = C:/jdk1.6.0_21
java version "1.6.0_21-ea"
Java(TM) SE Runtime Environment (build 1.6.0_21-ea-b03)
Java HotSpot(TM) Client VM (build 17.0-b13, mixed mode, sharing)

FYI: To run the configuration tool in custom UI mode, use
sh kSupport.sh -custom

To run the configuration tool in custom console mode,use
sh kSupport.sh -console
java.lang.NoClassDefFoundError: run
Caused by: java.lang.ClassNotFoundException: run
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
Could not find the main class: run. Program will exit.
Exception in thread "main"
All the default information has been collected. Please remember to send t
zip file in the directory ITG_HOME/bin/support/zipfiles to ITG support.
2 REPLIES
roxor
Honored Contributor.

Re: Error running ksupport.sh

Hello Abdullah,

we had the similar issue few days ago. have a look on this http://support.openview.hp.com/selfsolve/document/FID/DOCUMENTUM_QCCR1L24526

When updating kSupport be sure that you copy paste code from link in UTF!
Abdullah Rafiq
Respected Contributor.

Re: Error running ksupport.sh

Hey Roxor,
Thanks for pointing me to to the KB.
I tried the recommended solution on the site and after get the following error when running kSupport.sh .... I've also attached our kSupport.sh file if you can figure it out.

arafi744@HDQNCVMPPMD1 ~
# cd d:/itg/bin

arafi744@HDQNCVMPPMD1 /cygdrive/d/itg/bin
# sh ksupport.sh
ksupport.sh: line 19: $'\r': command not found
ksupport.sh: line 20: $'\r': command not found
ksupport.sh: line 26: $'\r': command not found
ls: cannot access d:: No such file or directory
lsc=
uname=CYGWIN_NT-5.2
ksupport.sh: line 33: syntax error near unexpected token `else'
'support.sh: line 33: `else