The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Error in Dev Restoration

Highlighted
GMohanty
Super Collector

Error in Dev Restoration

Hi HP Support,

Our Dev Application server had crashed.All files were lost. So the Prod image was restored into Dev from the client end.

We tried to configure the server by running kConfig.sh and mapping the Dev Server with the Dev database.

However, there was an error and the Server was not being able to Start.
We cloned the data from Prod and imported the data from prod.

Still we are facing an error while starting the server
server:main:com.kintana.core.server:2009/07/31-17:54:26.888 GMT+08:00: ERROR: Could not insert server property.
server:main:com.kintana.core.server:2009/07/31-17:54:26.888 GMT+08:00: key =
server:main:com.kintana.core.server:2009/07/31-17:54:26.888 GMT+08:00: value =
server:main:com.kintana.core.server:2009/07/31-17:54:27.153 GMT+08:00: java.sql.SQLException: ORA-01400: cannot insert NULL into ("APPPPM"."KNTA_APP_SERVER_PROPERTIES"."KEY")

Please help. Its urgent.Attached is the serverlog.
10 REPLIES
Rich Y_1
Member

Re: Error in Dev Restoration

I took a look at the server log. It looks like you have an issue logging into the DB. You may want to make sure that the correct ID and password are stored in the config file.
GMohanty
Super Collector

Re: Error in Dev Restoration

Thanks for your reply. Which config file are you refering to? We have correctly set the password by running kConfig.sh

prabu.karunanit
Regular Collector

Re: Error in Dev Restoration

Hi,

Please check your server.conf file where it is located in the ITG_Home.

In that file,Please check the DB Parameter are correct and is it rightly pointing to your Dev Environment.


Thanks,
Prabu
GMohanty
Super Collector

Re: Error in Dev Restoration

We checked the trigger KNTA_LOGON_T1. It has a query
server_name = SELECT MAX(server_name)
FROM KNTA_APP_SERVER_PROPERTIES
WHERE KEY = 'PRIMARY_SERVER'
AND value = 'true'

In serverlog the error is cannot insert NULL into ("APPPPM"."KNTA_APP_SERVER_PROPERTIES"."KEY").

So this is where the problem is.
We checked the data in the table knta_app_server_properties. Server Name is coming as PPM_Prod which is wrong. We had set the Server Name as PPM by using kConfig.sh

Any idea on why is this not updated in the table(KNTA_APP_SERVER_PROPERTIES)?
prabu.karunanit
Regular Collector

Re: Error in Dev Restoration

Hi,

The parameter values are set in the sever.conf file.

As i told you earlier, it is located in the ITG_HOME.

Please check the Base url and other server parameter settings. i guess your server parameter settings are not set properly.

KNTA_APP_SERVER_PROPERTIES table takes the value from this sever.conf file.


Thanks,
Prabu
Niraj Prabhu
Frequent Visitor

Re: Error in Dev Restoration

Hello,

Can you confirm if the following parameter values are correct?
SERVER_ENV_NAME
KINTANA_SERVER_NAME
BASE_URL
SERVER_NAME

You can modify the server.conf by opening it in editor. Make sure that these values are set correct. Did you replace the license.conf with the correct file for this development server having correct count?

In addition, execute
nohup sh kStart.sh &
under bin directory and the output can be seen in Bin folder. Share this file to understand what is the problem.
Niraj P.
Jim Esler
Honored Contributor

Re: Error in Dev Restoration

Any time you edit server.conf, you must run kUpdateHtml.sh to propagate the changes to all of the places they need to be.
GMohanty
Super Collector

Re: Error in Dev Restoration

Hi,

I checked the values of
SERVER_ENV_NAME
KINTANA_SERVER_NAME
BASE_URL
SERVER_NAME
These are all rightly set by editing server.conf.
I have also run kUpdateHTML.sh
The license.conf is also that of Dev instance only.
GMohanty
Super Collector

Re: Error in Dev Restoration

The Dev Server is a mirror image of Prod after restoration. Even the login credentials is that of Prod Server now.

One surprising thing is that though we had deleted the Windows Services named as PPM_Prod by using the ksvc utility,when we hard booted the Dev Server this PPM_Prod Service appeared again.
GMohanty
Super Collector

Re: Error in Dev Restoration

Attached is the output of nohup.out
Its the same as serverlog.
//Add this to "OnDomLoad" event