Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

EXTERNAL_WEB_PORT not starting up

SOLVED
Go to solution
Highlighted
Jason Nichols K
Honored Contributor

EXTERNAL_WEB_PORT not starting up

We're trying to setup an external web server to use with our PPM server.  On the dev server, we set the EXTERNAL_WEB_PORT to 11010 and it started up just fine.  Using netstat -a | grep LISTEN shows the open port waiting for connections.  However, when we make the same addition to the server.conf file and restart the server, the port does not open.  We have tried using other ports to no avail.  Right now, it configured for port 11111 and when we set the DEFAULT_SERVER_LOGGING and SYSTEM_THRESHOLD to DEBUG, these are the only lines that show up in the log file for this port number:

 

serverLog_20120320_202729.txt:INFO server:main:com.kintana.core.server.ServerStartupSanity:2012/03/20-20:27:13.666 CDT: Checking port availability for EXTERNAL_WEB_PORT=11111
serverLog_20120320_202729.txt:DEBUG server:main:com.kintana.core.server.ServerStartupSanity:2012/03/20-20:27:13.713 CDT: Checking com.kintana.core.server.EXTERNAL_WEB_PORT=11111
serverLog_20120320_202729.txt:DEBUG server:main:com.kintana.core.server.ServerStartupSanity:2012/03/20-20:27:13.713 CDT: Adding:com.kintana.core.server.EXTERNAL_WEB_PORT=11111

 

There is no error that the port cannot be opened, but there are also no other messages indicating that the port was successfully opened.

 

With the same logging parameters on another server, using the same 11111 port number, these lines appear in the log file and the port is successfully opened:

 

../server/Server/log/serverLog_20120320_202148.txt:DEBUG :main:org.apache.jk.server.JkCoyoteHandler:2012/03/20-20:21:47.841 EDT: setProperty port 11111
../server/Server/log/serverLog_20120320_202148.txt:DEBUG :main:org.apache.commons.modeler.Registry:2012/03/20-20:21:48.295 EDT: Managed= jboss.web:type=Connector,port=11111,address=0.0.0.0
../server/Server/log/serverLog_20120320_202148.txt:DEBUG :main:org.apache.commons.modeler.BaseModelMBean:2012/03/20-20:21:48.296 EDT: preRegister org.apache.catalina.connector.Connector@1bdbfec jboss.web:type=Connector,port=11111,address=0.0.0.0
../server/Server/log/serverLog_20120320_202148.txt:DEBUG server:main:com.mercury.itg.core.debug.monitor.PPMJbossMonitor:2012/03/20-20:21:48.296 EDT: ObjectName:
 'jboss.web:type=Connector,port=11111,address=0.0.0.0' matched '*:*'
../server/Server/log/serverLog_20120320_202148.txt:DEBUG server:main:com.mercury.itg.core.debug.monitor.PPMJbossMonitor:2012/03/20-20:21:48.297 EDT: Subscribed to: { objectName='jboss.web:type=Connector,port=11111,address=0.0.0.0', listener ='debug.monitor:service=PPMJbossMonitor', handback=null, filter=null }
../server/Server/log/serverLog_20120320_202148.txt:DEBUG server:main:com.mercury.itg.core.debug.monitor.PPMTomcatMonitor:2012/03/20-20:21:48.297 EDT: ObjectName: 'jboss.web:type=Connector,port=11111,address=0.0.0.0' matched '*:*'
../server/Server/log/serverLog_20120320_202148.txt:DEBUG server:main:com.mercury.itg.core.debug.monitor.PPMTomcatMonitor:2012/03/20-20:21:48.298 EDT: Subscribed
 to: { objectName='jboss.web:type=Connector,port=11111,address=0.0.0.0', listener='debug.monitor:service=PPMTomcatMonitor', handback=null, filter=null }
../server/Server/log/serverLog_20120320_202148.txt:DEBUG :main:org.apache.catalina.connector.Connector:2012/03/20-20:21:48.298 EDT: Creating name for connector jboss.web:type=Connector,port=11111,address=0.0.0.0

 

As you can see, there's more being done to get the port open, but Production server just doesn't seem to get to that point.  The server itself starts up normally otherwise and is fully functional in every other respect.

1 REPLY
Jason Nichols K
Honored Contributor
Solution

Re: EXTERNAL_WEB_PORT not starting up

We had another maintenance window last night to try to work on this issue again.  I shut down the server, cleared out the tmp and work directories, reran kUpdateHtml and kJSPCompiler scripts and started the server back up.  This time, the port opened up.

//Add this to "OnDomLoad" event