The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Deployment of PPM 8.0 Service Pack 2 fails!

SOLVED
Go to solution
Highlighted
Sascha_1
Member

Deployment of PPM 8.0 Service Pack 2 fails!

Hi,

 

during the service pack 2 deployment of PPM 8.0, i got the following error in the upgrade_core/ddl/KWFL_WORKFLOW_STEPS_NLS_800SP2_1.sql

It seems, that the system already uses an index for this columns, or? Any ideas?

 

SQLM: ORA-01408: such column list already indexed
ORA-06512: at line 31

ERROR:

 

*** running upgrade_core/ddl/KWFL_WORKFLOW_STEPS_NLS_800SP2_1.sql
DECLARE

     l_index_exists NUMBER :=0;

BEGIN

     DBMS_OUTPUT.Put_Line('File kwfl_workflow_steps_nls_810.sql started at ' ||
TO_CHAR(CURRENT_DATE, 'MON-DD-YYYY HH24:MI:SS'));

     BEGIN
      SELECT 1
      INTO l_index_exists
      FROM DUAL
      WHERE EXISTS
           ( SELECT 1
               FROM USER_INDEXES ui
              WHERE (ui.table_name = 'KWFL_WORKFLOW_STEPS_NLS'
                       AND
                       ui.index_name = 'KWFL_WORKFLOW_STEPS_NLS_U2') );
      EXCEPTION
        WHEN NO_DATA_FOUND THEN
          l_index_exists := 0;
    END;


    IF (l_index_exists = 1) THEN
       DBMS_OUTPUT.Put_Line( 'Index kwfl_workflow_steps_nls_u2 exists. Patch kwf
l_workflow_steps_nls_810.sql already run against this
DB instance.' );
    ELSE
       IF (l_index_exists = 0) THEN
           DBMS_OUTPUT.Put_Line( 'Creating index kwfl_workflow_steps_nls_u2' );
             EXECUTE IMMEDIATE 'create index kwfl_workflow_steps_nls_u2 on kwfl_
workflow_steps_nls (workflow_step_id, enabled_flag) COMPUTE

STATISTICS';
       END IF;

    END IF;

    DBMS_OUTPUT.Put_Line('File kwfl_workflow_steps_nls_810.sql completed at ' ||
 TO_CHAR(CURRENT_DATE, 'MON-DD-YYYY

HH24:MI:SS'));
END;

 

Best regards

Sascha

3 REPLIES
Sascha_1
Member

Re: Deployment of PPM 8.0 Service Pack 2 fails!

Attached, you'll find the screenshot of the affected table "KFWL_WORKFLOW_STEPS_NLS".

There, you can see the existing indexes.  If i run the select statement from the sp2 deployment script, i got no entries.

 

SELECT *
               FROM USER_INDEXES ui
              WHERE (ui.table_name = 'KWFL_WORKFLOW_STEPS_NLS'
                       AND
                       ui.index_name = 'KWFL_WORKFLOW_STEPS_NLS_U2')

 

So it seems, the system can't create the new index, named in the attached sql file.

 

Regards

Sascha

Sascha_1
Member

Re: Deployment of PPM 8.0 Service Pack 2 fails!

The system already created an indexed with the same column definitions:

 

KWFL_WORKFLOW_STEPS_U2

 

So should i delete the index?  Is this a known error during the SP2 deployment procedure?

 

Regards

Sascha

Sascha_1
Member
Solution

Re: Deployment of PPM 8.0 Service Pack 2 fails!

Hi @all,

 

problem will be fixed with the new service pack release of SP2. This is a known error, if you upgrade from PPM 7.5 SP6 or higher.

 

Fore more information, see the release notes of the PPM 8.0 Service Pack 2

 

Regards

Sascha

//Add this to "OnDomLoad" event