Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Demand mgmt request - problem with validation & submit button

Highlighted
b460
Regular Collector

Demand mgmt request - problem with validation & submit button

Hi,

We have PPM 7.1 used within our firm. Lately he have an issue in out TEST environment in which the following happens when creating a new request:

Fields are not validating after you enter text. For example, if there is a name field asking to enter your first name, if I enter the name and click away from the field, the field will not validate. It just stays there as text.

If you enter text in the field and then click the validation button next to it (Auto Complete List) it fails to open.

Finally, when you click the Submit button, the button greys out and the page just hangs (nothing happens and the request is not submitted).

Has anyone come across this problem before or may know what is going on?

Cheers.
6 REPLIES
Mahen M
Honored Contributor

Re: Demand mgmt request - problem with validation & submit button

Are you using clustered environment in the test area?

Do you get scripting error in the bottom left hand corner of IE?

Execute the script 'kRunCacheManager.sh A' under you bin directory which is present in where you have installed PPM.

Clear your browser cache and try again.

If this does not work, Kindly share your Query for validation.

Regards,
Mahendran M
b460
Regular Collector

Re: Demand mgmt request - problem with validation & submit button

We are using a SaaS environmnet, we have tried restarting the service but that has not solved anything.

There are no scripting errors produced by IE either.

What exacly does the kRunCacheManager.sh script do?
Mahen M
Honored Contributor

Re: Demand mgmt request - problem with validation & submit button

It clears the system cache, Can you show the Query of the validation?

Regards,
Mahendran M
Erik Cole
Honored Contributor

Re: Demand mgmt request - problem with validation & submit button

Hi Ben,

Chances are you have a validation or a rule that is causing an error - this causes symptoms like you're describing.

It's also possible that there is a browser issue. What browser/version are you using?
b460
Regular Collector

Re: Demand mgmt request - problem with validation & submit button

We are using Internet Explorer 6. The issue does not exist on our DEV or PROD environment.

I will investigate the validations and see if that is causing the problem.

Sorry I cant post the validation query at this time as the problem is happening on multiple fields (over 15). Not sure which one it would be.
Mahen M
Honored Contributor

Re: Demand mgmt request - problem with validation & submit button

See if the Validation has 2 values in select clause....

Regards,
Mahendran M
//Add this to "OnDomLoad" event