Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Custom link problem

SOLVED
Go to solution
Highlighted

Custom link problem

Hi everyone!,

 

I'm having a strange behavior with a custom link. I created a field with a textfield validation of 200 charaters, in read only mode. The value of the link is calculated with a simple rule, which sets this value:

 

<!--HTML--><a target="_blank" href="/itg/fm/FinancialSummary.do?fsId=31146">Central de Riesgos por Operación - CRO</a>

 

The purpose is to open the Financial Summary in a new window (like the original one does) in order to edit the FS. The problem is that the link is opened but in the same Windows that the project and show as container of the detail summary tab.

 

When I tried to edit the FS, the window i reload again in the project page and the table is empty despise there are records on the FS.

 

Anyone can give me a tip of what can be happening???

 

Regards,

Alfredo

3 REPLIES
alex-h
Member
Solution

Re: Custom link problem

We use target="_new" : open the link on a new tab.

Derek Giedd
Frequent Visitor

Re: Custom link problem

Here is the code for a Page Load Rule we use with the Request ID as a dependency and the FS field as a result.  Just change the server name.  This opens the FS in a new window.

 

SELECT CASE WHEN nvl('[REQ.REQUEST_ID]','x') = 'x' THEN NULL
         ELSE '<!--HTML--><a href='|| REPLACE(VALUE,'.com/','.com')||'/itg/fm/FinancialSummary.do?fsId='||p.prj_financial_summary_id||'  target="_blank">'||'Financial Summary'||'</a>'
         END,
       CASE WHEN nvl('[REQD.VP.EPM_PROJECT_NO]','x') = 'x' THEN NULL
         ELSE '<!--HTML--><a href='|| REPLACE(VALUE,'.com/','.com')||'/itg/fm/FinancialSummary.do?fsId='||p.prj_financial_summary_id||'  target="_blank">'||'Financial Summary'||'</a>'
         END
  FROM knta_app_server_properties A, kcrt_fg_pfm_project p
 WHERE KEY = 'BASE_URL'
   AND server_name = '__CLUSTER_DEFAULT__'
   and p.request_id = '[REQ.REQUEST_ID]'
-- Remember to give Kudos to answers! (click the KUDOS star)

Re: Custom link problem

Hi Alex,

 

the target _new doesnt exist in HTML, what would do is to find a TAB or page called new and open the page there, could be useful if I set a page name different or dynamic could work.

 

Like I said, sometimes the link works fine and sometimes dont, seems like a browser behavior.

 

Thanks for your comments!

 

Alfredo

//Add this to "OnDomLoad" event