Project and Portfolio Management Practitioners Forum
cancel

Changing table component rows directly at the DB level does not show up on UI

SOLVED
Go to solution
Highlighted
dlinetsk
Super Contributor.

Changing table component rows directly at the DB level does not show up on UI

Hi guys, 

 

Hope someone can give me a tip on the following issue:

 

We update rows in a table component on a request form using PL/SQL procedure. The updates go ok, we set last_update_date, last_updated_by and entity_last_update_date in kcrt_requests and knta_parameter_set_context table. We also set last_updated_by and last_update_date in kcrt_request_details and kcrt_table_entries to make the changes to show in UI.

 

But the changes do not show up in UI unless we run a cache manager to clear cache 8.

 

Please share ideas/tips on how to make the changes show up without cache manager run.

 

Thanks,

Dmitry

3 REPLIES
mike_se
Acclaimed Contributor.
Solution

Re: Changing table component rows directly at the DB level does not show up on UI

Hi Dmitry,

 

Looks like this has come up in the past.

 

See:

http://support.openview.hp.com/selfsolve/document/KM1403926

"Table Component Updates via PL/SQL are not reflected unless you clean the application cache?"

 

The OPTION #4 looks like the one most related to the desired functionality, which is basically to disable the Table Component caching.

 

-Mike

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
pepdwill
Honored Contributor.

Re: Changing table component rows directly at the DB level does not show up on UI

Yes - as Mike said, disabling the TC caching should make your db updates show up immediately.  

dlinetsk
Super Contributor.

Re: Changing table component rows directly at the DB level does not show up on UI

Thank you Mike, this is what we were looking for.