Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't Start PPM 8 Service.

Highlighted
Ing. Raul Rueda
Occasional Contributor

Can't Start PPM 8 Service.

I managed to successfully install the PPM 8 in a virtual machine, but when I restart my computer and it started again my virtual machine I canâ t Start PPM 8 .

When I run kStart.sh Script generate this error:

JAVA_HOME = C:/jdk1.6.0_23
Server will start in standalone mode...
server:main:SystemOut:2011/03/04-14:38:44.472 GMT-05:00: Logging reconfiguration complete
:main:org.apache.coyote.http11.Http11BaseProtocol:2011/03/04-14:39:11.769 GMT-05:00: Error initializing endpoint
java.net.BindException: Address already in use: JVM_Bind:8080
at org.apache.tomcat.util.net.PoolTcpEndpoint.initEndpoint(PoolTcpEndpoint.java:297)
at org.apache.coyote.http11.Http11BaseProtocol.init(Http11BaseProtocol.java:138)
at org.apache.catalina.connector.Connector.initialize(Connector.java:1016)
at org.jboss.web.tomcat.tc5.StandardService.initialize(StandardService.java:688)
at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:791)


the complete log here:
http://dl.dropbox.com/u/18123184/arranque.txt

postscript. I installed SP1 and SP2.
If I work with SnapShot of the virtual machine, function properly the problem is when I restart my computer.

Thanks,
2 REPLIES
Jim Esler
Honored Contributor

Re: Can't Start PPM 8 Service.

The log indicates PPM cannot open port 8080 because another application has already opened it. You could use a web browser to access the port and see what you get. If it is your PPM instance, it was restarted automatically. If it is something else, you will either have to disable that application or reconfigure PPM to use a different port.
Ing. Raul Rueda
Occasional Contributor

Re: Can't Start PPM 8 Service.

I solved this problem. immediately after restarting the VM, I stopped the windows PPM service . and then started the PPM service with kStart.sh Script. and fixed, PPM starts perfectly. Thanks.
//Add this to "OnDomLoad" event