Project and Portfolio Management Practitioners Forum
cancel

Can not find a field in a rule in a multi language environment

SOLVED
Go to solution
Highlighted
sevcan
Super Contributor.

Can not find a field in a rule in a multi language environment

Hey,

 

I created a new radio button(yes-no) field in the request header. I saved it and reopen the request type. I was going to write a apply on field change rule with this field but when I search it in the rule ondition it did not appear. The environment is multi language, English- TUrkish. They are using it Turkish.  do the configuration in English.

 

Do  you have any idea why the field did not appear on the search list. It is diplay, display only, display on Search and filter are yes.

 

Thanks,

Sevcan

3 REPLIES
Celil
Acclaimed Contributor.
Solution

Re: Can not find a field in a rule in a multi language environment

Hi Sevcan,

 

Radio button fields do not work with rules. This is a known product limitation and there is already an enhancement request logged for it:

 

ENHANCEMENT# 206503 - 'Radio Button' is not available as a dependency in request rules

 

This is currently not documented but RnD have created a documentation a while ago for it: QCCR1L26328.
You can track its progress on the following link:
http://support.openview.hp.com/selfsolve/document/FID/DOCUMENTUM_QCCR1L26328

 

It is necessary to use dropdown lists to overcome this deficiency.

 

PS: If the post resolves your issue, please click KUDOS star icon and mark it as Accepted Solution.

 

 

Celil

IT Governance Professional
& PPM Solution Architect
sevcan
Super Contributor.

Re: Can not find a field in a rule in a multi language environment

thanks
SureshR
Super Contributor.

Re: Can not find a field in a rule in a multi language environment

I have a trick to apply the rule on Radio button.

 

1) Create the required field as drop down box.

2) Create a rule for this Drop Down and save the Request Type.

3) Change the field validation from Drop Down to Radio.

 

I have implemented the same in my system and it is working fine. Go ahaed and Enjoyee!!!

 

Cheers!