Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Auto Start of the PPM after Server reboot

SOLVED
Go to solution
Highlighted
Rahul Varshney
Acclaimed Contributor

Auto Start of the PPM after Server reboot

We have HP PMM version 7.1 installed on HP UX V1. We now want to have auto start of the PPM when server is restarted. We have called the kStart.sh script is startup script in init directory. However application is up for some minutes only after that it goes down on its own. Can you please provide me any solution in this regard?
4 REPLIES
Jim Lembo
Acclaimed Contributor
Solution

Re: Auto Start of the PPM after Server reboot

I believe you need to "nohup kStart.sh".

Re: Auto Start of the PPM after Server reboot

Hi,

i have attached a possible solution.
YOu must set com.kintana.core.server.REMOTE_ADMIN_REQUIRE_AUTH=false in server.conf.

Regards
Volker

#!/bin/bash

# Path to PPM BIN Directory
PPM_BIN=/app/ppm/bin
PPM_USR=ppm
#JAVA_HOME=

. /etc/rc.status

# Reset status of this service
rc_reset

case "$1" in
start)
echo -n "Starting HP PPM"
su - $PPM_USR -c "cd $PPM_BIN; sh $PPM_BIN/kStart.sh"

rc_status -v
;;
stop)
echo -n "Stopping HP PPM"
su - $PPM_USR -c "cd $PPM_BIN; sh $PPM_BIN/kStop.sh -now"

rc_status -v
;;
*)
echo "Usage: $0 {start|stop}"
exit 1
;;
esac

rc_exit
Rahul Varshney
Acclaimed Contributor

Re: Auto Start of the PPM after Server reboot

Hi All,

Thanks. both the options have been worked. we have used the script as provided with nohup option. it is working now.

Regards,
Rahul varshney
Rahul Varshney
Acclaimed Contributor

Re: Auto Start of the PPM after Server reboot

script as provided has been used with nohup. it is working as expected.
//Add this to "OnDomLoad" event