Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

'Attachment File could not be downloaded.' error after report is run successfully

Highlighted
Cindy Ramberg
Regular Collector

'Attachment File could not be downloaded.' error after report is run successfully

Hi,

We have a custom report that is successfully processing data. However, after completion, we receive an Error that states "Attachment File could not be downloaded. The File: rep_#####.html no longer exist in the server. Please contact your HP Project and Portfolio Manangement system adminstrator. (KNTA-10697)'. We plan to add a command to output a page for the user, but hoping to resolve this error first.

I searched the HP support website but didn't see any info regarding this error. I am attaching the code and screen shots.

Any help is appreciated!
Thanks!
cindy
4 REPLIES
Sascha Mohr_1
Esteemed Contributor

Re: 'Attachment File could not be downloaded.' error after report is run successfully

Hi
the error happens because you don't have the second command. To eliminate it you need a command that starts with
ksc_begin_script [AS.REPORT_DIR][RP.FILENAME].html
Then the HTML and ksc_end_script.
Without this you will receive the described errro.
Cindy Ramberg
Regular Collector

Re: 'Attachment File could not be downloaded.' error after report is run successfully

Hi Sascha,
We seem to have those commands in that order for our output page that we were going to add. But, we haven't enabled that yet.

Are you saying we should add the output page begin_script/html/end_script commands within the original report code?

Thanks MUCH!
cindy
Cindy Ramberg
Regular Collector

Re: 'Attachment File could not be downloaded.' error after report is run successfully

Hi Sascha,
I did some more testing and discovered that the ksc_begin and ksc_end scripts are definitely the answer. When I copied the new ouput page that I was going to use into the original script it worked. I also discovered that it did NOT like comment my comment line.

It's working now!
Thanks for your help!
Cindy Ramberg
Regular Collector

Re: 'Attachment File could not be downloaded.' error after report is run successfully

closing thread
//Add this to "OnDomLoad" event