Project and Portfolio Management Practitioners Forum
cancel

Anyone use vshell on their PPM server? Having trouble scp to multiple windows drive letters

Highlighted
bzdafro
Honored Contributor.

Anyone use vshell on their PPM server? Having trouble scp to multiple windows drive letters

Hi,

 

I am trying to copy a file from a source server (windows) to dest server (windows (running vshell), to G: drive).  I can deploy to dest server E: drive, but no other drive letter.   I am hoping someone might be running vshell, or know some windows environment settings/ or unix commands that might correct the issue.

 

We have cygwin as well as vshell installed on our PPM windows server .  vshell manages the secure copy protocol, and sets up a virtual path for the scp command.   It only allows 1 virtual mapping per protocol.  We have been using this for years without any issue.  The scp virtual root is set to E:\Staging  in vshell.   The built in ksc_copy_server_server works fine and deploys to starting path E:\Staging.   We recently added a G drive to the PPM server.   I am trying to get scp or ksc_copy_server_server to deploy to G:\Staging but everything I try fails.  PPM doesnt know what the G drive is.

 

I can run scp between any two windows servers running Cygwin (and not vshell) by using scp -p "filename" id@targetserver:/cygdrive/g/some_path/filename (using the cygdrive path) scp resolves that fine.

If I try to run the above command to the target server running vshell, it doesnt know what "cygdrive" is. I can issue 'mount' and cygdrives are listed, but vshell somehow doesnt read it. It only uses its virtual path maps (which is limited to one) or system environmental variables (which dont seem to work when called from PPM)

 

After wasting many hours on this, I tried a scp pull instead. I tested on the dest server and it works fine. scp id@sourceserver:/cygdrive/e/somepath/somefile . The file gets pulled and dropped off in the current directory (which happens to be drive letter G). I run the same command in PPM in the object type, and I get an error "Inappropriate ioctl for device"     I've seen that error before in PPM, but I cant remember what it means. Should I be able to issue a scp pull from the object type commands? I am runnning the command below as ksc_simple_command since scp will be waiting for the password. Otherwise, do you know any other way to issue the ksc_copy_server_server to different drive letters? Right now I put a work around in place... I am copying to the E drive, then issuing a mv command and moving it to the G drive. Thats the only way I found to get this working.

 



1 REPLY
Utkarsh_Mishra
Acclaimed Contributor.

Re: Anyone use vshell on their PPM server? Having trouble scp to multiple windows drive letters

Hope the attached document will solve your problem. This is docuemnt was shared by Mercury.

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)