Project and Portfolio Management Practitioners Forum
cancel

Adding resource to WBS problem

SOLVED
Go to solution
Highlighted
TurboMan
Honored Contributor.

Adding resource to WBS problem

Hi,

 

Recently, we've upgraded from PPM 9.14 to 9.21.

But, we began to get some security kind of issues.

One of the problem is,

When a resource manager tries to add a resource in WBS it sounds like it adds but it doesn't save.

We never had this problem in Ver 914.

I've started to debug the JavaScript, found out that a negative taskid pass to the viewWorkPlanHelper.isSelectedTaskBelongToUser function in ViewWrokPlanHelper.js file.

 

I don't have any problem of adding any resource if the user is project manager.

 

Any help is appreciated.

 

Regards

T.M.

2 REPLIES
TurboMan
Honored Contributor.

Re: Adding resource to WBS problem

Hi,

 

I opened a case to get support from HP experts.

They said that they replicated the problem.

And found out that there was a bug in V9.21.

I am waiting for a solution may be a hotfix.

If I get a workaround I will be sharing with the forum.

 

Regards

T.M.

randull
Acclaimed Contributor.
Solution

Re: Adding resource to WBS problem

Hi TurboMan,

 

Related to your issue, please replace the JS file with the same file in server\<your server>\deploy\itg.war\js\pm and let us know if you can reproduce this issue.

 
Please try this on stage first.
Best regards,
Randall

-- Remember to give Kudos to answers! (click the KUDOS star)
"If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”