Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Actuals do not rollup from TM to Workplans accurately

Highlighted
Cenk Oguz
Regular Collector

Actuals do not rollup from TM to Workplans accurately

At our client site we are using the option to rollup actual hours and costs from Time Management into Project Workplans.

However we have just noticed that quite many projects have differing totals in Workplan Labor hours/costs and Time Management hours/costs.

In most cases the diff is quite small, not more than a few percent (which is bad enough in the hour rollup at least), but in many projects we see diffs ranging from 20%-80%.

We know cost contouring did not work perfectly before, but in our case the actual hour rollup is inaccurate as well.

Has anyone seen this in the systems? We are using PPMC 7.1

Regards,
Cenk
9 REPLIES
Alessandro Baio
Super Collector

Re: Actuals do not rollup from TM to Workplans accurately

Hi Cenk,

I observed the same behaviour at a customer site. We're still investigating to solve the problem. Actually we're using a routine, provided by the HP Support, that bring the project actuals in synch again with the entered time.
Unfortunally, after a few days some of the projects went out of synch again.
At the moment we haven' got a definitive solution and the root cause is still unknown, as far as I know.
Best Regards,
alessandro
Cenk Oguz
Regular Collector

Re: Actuals do not rollup from TM to Workplans accurately

Hi!

Yes we have been notified of a script kPMTMSync.sh that synchronized TM/PM actuals.

It worked in a few projects, and failed with an exception in others.

I will follow up on this with HP support to get a solution.

FYI it appears costs are not synchronized with closed down projects and workplans at least. Perhaps they need to be opened before syncing.

/Cenk
Alessandro Baio
Super Collector

Re: Actuals do not rollup from TM to Workplans accurately

Hi,

the kPMTMSynch is exacly the same script we are running, with some failures as well.
Let's keep in touch to share further info on this topic.
Thank you,
Regards.
alessandro
Cenk Oguz
Regular Collector

Re: Actuals do not rollup from TM to Workplans accurately

Hey Alessandro!

We have a case id 1600091644 at HP support on this. Perhaps they will put higher priority on this issue if several customers refer to the problem.

/Cenk
Erik Cole
Honored Contributor

Re: Actuals do not rollup from TM to Workplans accurately

One thing we noticed is if we set COST_ROLLUP_INTERVAL_MINUTES too low (we tried 20 min) then sometimes it didn't run at all, even though ours isn't a busy server and CSO told us it shouldn't cause any problems.

We reset it to 30 min, and it seems fine.
Cenk Oguz
Regular Collector

Re: Actuals do not rollup from TM to Workplans accurately

It appears the exception we experienced in some projects was due to us filling in an incomplete project name argument to the script.

Swedish characters did not make it into the unix console when pasting.
It should not throw an exception in any ways.

So the script appears to workout, however the cause of the desynchronization still appears to be there.

/Cenk
Inci Kilicaslan
Acclaimed Contributor

Re: Actuals do not rollup from TM to Workplans accurately

Hello Cenk,

We have the same issue and our case is registered in HP. Case id is 1601231218.

We run the that TMPMSync tool regularlay to fix the problems. We are waiting for the support to find a solution.

Is there any progress on your side?

Regards,

Inci
Cenk Oguz
Regular Collector

Re: Actuals do not rollup from TM to Workplans accurately

Hi Inci!

We have notified our HP support contact and prioritized this issue.

They are actively working on it, asking for datadumps and sending debug patches to me.

No apparent progress yet though.

/Cenk
Erik Cole
Honored Contributor

Re: Actuals do not rollup from TM to Workplans accurately

This seems to still be an issue in 2014 and in release 9.22

 

Can anyone comment on what - if any - solutions they have received?

//Add this to "OnDomLoad" event