Project and Portfolio Management Practitioners Forum
cancel

9.1 workplan Edit resorce

SOLVED
Go to solution
Highlighted
WissenCarquest
Super Contributor.

9.1 workplan Edit resorce

Hello Team We have recently upgrade from 7.1 to 9.10. while we edit workplan for change resource for task. We got "Too Many Results" window. It is showing "The search you are about to run is returning 369 number of results. You must provide additional filters to limit the size of the result set to 99" message. Please let me know how to avoid this message.
8 REPLIES
WissenCarquest
Super Contributor.

Re: 9.1 workplan Edit resorce

 
jsalass
Honored Contributor.

Re: 9.1 workplan Edit resorce

Hi WissenCarquest,

 

Please check the value for this server parameter RESOURCE_FINDER_SEARCH_MAX_USERS in the server.conf.

 

The default value is 100. So, if it is not in the server.conf file so add it in your primary server section with a higher value.

 

For further information check the installation guide on page 437.

 

Hope this helps!.

 

Regards,

Jonathan

 

 

jsalass
Honored Contributor.

Re: 9.1 workplan Edit resorce

This parameter should resolve your issue. :)
WissenCarquest
Super Contributor.

Re: 9.1 workplan Edit resorce

Hi, I have added below parameter. Still I am geting message. Please find the attached doc.

com.kintana.core.server.RESOURCE_FINDER_SEARCH_MAX_USERS=450

jsalass
Honored Contributor.

Re: 9.1 workplan Edit resorce

Hi Wissen,

Could you please share your current PPM version and build?. I checked my 9.1 SP4 and it is working fine.

Also, do you know when the error started? any recent change?

Share your server.log, server configuration report and server.conf file.

Regards,
Jonathan
WissenCarquest
Super Contributor.

Re: 9.1 workplan Edit resorce

Hi, We have current version 9.14. Please find the attached server.conf and serverlog,txt. Please adives me on this.

jsalass
Honored Contributor.
Solution

Re: 9.1 workplan Edit resorce

Hi WissenCarquest,

 

I checked and the server log and server.conf looks fine.

 

I'm wondering if you stop the PPM server and run the kUpdateHtmlsh command (from command prompt PPM_HOME/bin folder) after you modified the parameter I provided?

 

Please let us know.

 

Regards,

Jonathan

d4y4n4
Honored Contributor.

Re: 9.1 workplan Edit resorce

Hi,

It is not recommended that make a resource pool with too many resources in it.
Too many resources in the resource pool will bring performance issue to the server.


As Jonathan mentioned , the "RESOURCE_FINDER_SEARCH_MAX_USERS" is used to set the max number of resource search result.
If it is absent in server.conf, the default value is 100.

However, there is an upper limit on it for performance issue, which is hardcoded as 300.
So if you want "RESOURCE_FINDER_SEARCH_MAX_USERS" to work, it can not be larger than 300.

Please try to break down your users into different resource pools, or use other filters, and set the "RESOURCE_FINDER_SEARCH_MAX_USERS" not large than 300.

Regards,
Dayana Campos