Operations Orchestration Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

No Table in MySQL SChema for HP OO Central 9.00

ThomasGIorgetti
Acclaimed Contributor

No Table in MySQL SChema for HP OO Central 9.00

Hi,

 

I'am testing HP's Orchestration Solution and i have an issue with the installation of Central and the link with his MySQL DB.

 

Actually during the installation steps of Central the link is ok, but at the end i have none of the 27 tables created in my Schema.

 

For the requirement i think i got everything :

- Running on a Win2k8R2 server

- .net framework 2.0 SP1 and 3.5 installed

- ASP.NET installed trough ISS Activation (I installed only ASP and his dependencies for the server manager)

- MySQL 5.5.25 with MySQL GUI Tools (Not MySQL Workbench)

- Visual C++ 2010 for both x86 and x64

 

For the MySQL installation i checked the InstallGuide.pdf and set Multilingual Support with UTF-8 as aked.

 

For the DB and User creation i tried either by using command line or the GUI

CREATE DATABASE oodata;

CREATE USER 'oouser'@'localhost' IDENTIFIED BY 'oopwd';

GRANT ALL PRIVILEGES ON oodata.*TO oouser@localhost ;

 

Then i launch the Central installer and make the connection with oodata

 

host: localhost

port: 3306 (I checked firewall exception during MySQL installation for this port)

DB: oodata

user: oouser

pwd: oopwd

Flagged Create or recreate schema

 

The installation goes without a problem, nut when i go check oodata there is no table created.

 

This is each step and requirement i made, but i still don't understand what go wrong. I check some topics here but without getting an answer.

 

Right now i'am checking logs again to see if i missed a point, but an advice would be much appreciated :)

 

Regards,

Thomas

 

 

2 REPLIES
smkzone
Acclaimed Contributor

Re: No Table in MySQL SChema for HP OO Central 9.00

Hi,

 

I faced the same issue last week. I wondered what could have went wrong as no indication of any such. Like you, I even tried going through the command line client for creating the DB and user.

 

When I change the mysql 5.5 to mysql 5.1  it worked all well without changing any of the steps. I assumed there is some problem with HP 9.00 + Mysql 5.5 combination. This could be very false assumption, but it worked for me. I could have digged in more as to why it ididn't work with 5.5, but that may deviate me from the primary task, so I left it.

 

The solution is Use "Mysql 5.1  instead of Mysql 5.5 "

 

Thanks

--

Regards

Murali Krishnan

--
Murali krishnan
Project Lead | Enterprise Automation Systems
CenturyLink Technologies
Highlighted
ThomasGIorgetti
Acclaimed Contributor

Re: No Table in MySQL SChema for HP OO Central 9.00

Hi,

 

Thanks for the answer, going to check that asap.

 

I'll keep an update for the results.

 

Regards,

Thomas

//Add this to "OnDomLoad" event