Network Management / (OpenView-NNM) Practitioners Forum

Trying to block traps

Honored Contributor.

Trying to block traps

Trying to block Symbol traps using the trapFilter.conf file.  I tried each of the follwing entries:

# 8 Jan 2014 Symbol Wireless Traps (. <*, .*>
<*, .*>
<*, .>

Saved the file and the ran /opt/OV/bin/nnmtrapconfig.ovpl -readFilter

When I run /opt/OV/bin/nnmtrapdump.ovpl -trapid . I still see the traps. Also the coun still rises when I look at [Tools][Total Traps Received by SNMP OID

Am I missing something?





“The world as we have created it is a process of our thinking. It cannot be changed without changing our thinking.”
― Albert Einstein
Outstanding Contributor.

Re: Trying to block traps


I think you are referring incorrect file,i don't remember the correct file name now.Please search it in the nnm guide.

Vishnu Babu V
Super Contributor.

Re: Trying to block traps



      Try the same process in nnmtrapd.conf file present in the same location in NNMi server.. and let us know if you getting traps...



Micro Focus Expert

Re: Trying to block traps



you can try to modify also the first part of the line:

<*.*.*.*, .*> instead of <*, .*>

You can also be more concrete if posible inserting the IP addresses of the sources.


You can check the OIDs bloqued using the following command:

#nnmtrapconfig.ovpl –dumpBlockList

And also checking the following file:



Once you modified it, you can use nnmtrapconfig.ovpl –stop/start with option –readFilter to force to read the changes made.



You can check what's happening with the traps once they arrive to NNMi server by enabling the following trace:

  • #nnmsetlogginglevel.ovpl FINEST
  • #nnmsetlogginglevel.ovpl com.hp.ov.nms.trapd FINEST
  • #nnmtrapdump.ovpl –last 5 –t when the traps arrive.
  • Confirm that they are in the console.

Once you complete the tests, set the tracing levels back to CONFIG:

  • #nnmsetlogginglevel.ovpl CONFIG
  • #nnmsetlogginglevel.ovpl com.hp.ov.nms.trapd CONFIG



Hope it helps


BEst Regards

Acclaimed Contributor.

Re: Trying to block traps

Oscar is correct, your wildcard supposition needs to cover all octets  for IPv4, the  * alone isnt proper unless you have IPv6  licenced and enabled. Its in the upper portion of the configuration file.


# Both IP Addresses and Event Oids can be specified using wild card "*"
# or range using "-".  The IP Address wildcard "*.*.*.*" indicates all
# IPv4 addresses, while "*" indicates all IP addresses in both IPv4 and
# IPv6 networks (when IPv6 support is licensed and enabled).




Have a nice day :)

Andy Kemp
I've lasted longer in the technology industry than most certifications.