LoadRunner Practitioners Forum
cancel

Tremendous lag in app running under LoadRunner

Highlighted
Rexxrally
Frequent Visitor.

Tremendous lag in app running under LoadRunner

My webapp (ASP.Net C#, Javascript, nothing special) runs quite rapidly normally.

When I record a script under LoadRunner, it runs equally quickly. When I play back the script, however, my shiny diamond turns to coal. Whereas it normally takes but a few seconds to transition from page to page, replaying under LoadRunner takes several minutes, and causes my app to timeout.

How can I fix this problem? Is there some things I should be looking at? This is all running in TruClient, BTW

3 REPLIES
AvniLior
Acclaimed Contributor.

Re: Tremendous lag in app running under LoadRunner

Hi Rexxrally,

a few questions:

what is the version of LoadRunner you are using?

which protocol are you using for recording? (web or TruClient)

if TruClient - which browser are you recording?

if web protocol - can you share any error messages you see in the log file? are there any network elements in between? is this recreated in another instance of LoadRunner you have installed?

Thank you,

Lior

Rexxrally
Frequent Visitor.

Re: Tremendous lag in app running under LoadRunner

Thanks for your help. 

We are running version 12.53 build 1203.

It's running in TruClient for IE Browser on Windows Server 2012 R2 Standard.

It's being recorded and run on the same server. I access the server from my PC via RDP.

This is a script that I run (all of them replay slowly, this is just one):

Action()
{
truclient_step("1", "Navigate to 'https://www.thewebsite.com/'", "snapshot=Action_1.inf");
truclient_step("2", "Click on Sign In link", "snapshot=Action_2.inf");
truclient_step("3", "Type MyUserID in Sign in to MyWebsite with... emailbox", "snapshot=Action_3.inf");
truclient_step("4", "Type ********* in Keep me signed in Sign in passwordbox", "snapshot=Action_4.inf");
truclient_step("5", "Press Enter key on Keep me signed in Sign in passwordbox", "snapshot=Action_5.inf");
truclient_step("6", "Click on eFiles", "snapshot=Action_6.inf");
truclient_step("8", "Click on Your File Number / Load...", "snapshot=Action_8.inf");
truclient_step("10", "Click on × javascript_link", "snapshot=Action_10.inf");
truclient_step("12", "Click on Yes button", "snapshot=Action_12.inf");
truclient_step("14", "Set C:\fakepath\MyFile.pdf on filebox (1) filebox", "snapshot=Action_14.inf");
truclient_step("16", "Click on element (3)", "snapshot=Action_16.inf");
truclient_step("18", "Click on My Account link", "snapshot=Action_18.inf");
truclient_step("20", "Click on Log Out menuitem", "snapshot=Action_20.inf");

return 0;
}

AvniLior
Acclaimed Contributor.

Re: Tremendous lag in app running under LoadRunner

Thank you Rex,

Additional question - can you check the same script on a different browser? (Chromium or FireFox?)

can you verify you have the latest patch (patch 4) installed on the machine?

Thanks,

Lior