LoadRunner Practitioners Forum

LoadRunner RDP sessions to windows 2008

New Member.

LoadRunner RDP sessions to windows 2008



What is the recommended way to run/record a script that uses RDP to a windows 2008 server ?


I've got a .rdp file that starts up an application on the server and it works fine by itself.

If I start a recording using this rdp file, it gets stuck trying to connect to the server.

Same thing happens if I choose "Run RDP Client".


I have also tried the  rdp_connect_server command directly (with LR rdp version set to 5.2) but  i get an error saying :

Error: Internal Error (call customer services): _pPlatformChallenge == NULL in LrRdpPlatformChallengePacket::send

The same command worked connecting to a Win 2003 server


I'm currently running LR 11 on WinXp


I also found a reference to  http://support.openview.hp.com/selfsolve/document/KM831889 but i do not have access to the document. Could someone share it's contents ?


Outstanding Contributor.

Re: LoadRunner RDP sessions to windows 2008

Hi Vince,


I'll try to get someone to answer your question.  Sorry can't get you the document. Those documents are part of the support contract service.

Michael Procopio
LinkedIn.com/in/Michael Procopio
Trusted Contributor.

Re: LoadRunner RDP sessions to windows 2008

Hi VinceYeo,


LR 11 is supported only 5.2 version of the RDP protocol.

Win XP updates the internal RDP client to version 6.0 or 6.1 (it depends on updates).

If you try to record a script via exteranl RDP client (5.2 version) it should work.

Or you can install Patch 1 on LR 11 GA.


- boo

If you play by the rules, you always lose
New Member.

Re: LoadRunner RDP sessions to windows 2008



would you be able to recommend on my end? Since the server is hosting server 2008, the downgrade of RDP won't be possible. Or, is there any patch for LR11 to record actions done on RDP 6.2?

Super Contributor.

Re: LoadRunner RDP sessions to windows 2008

LR11 Patch 2 should do the trick

New Member.

Re: LoadRunner RDP sessions to windows 2008

I am encountering the same issue and error message described in the first message posted in this string.

My environment is different


I see in the documentation that newer version of RDP are supported. Should the environment below work?


I am recording with VuGen 11.5

Running on a Windows 7 laptop

RDP client on the laptop is 6.1

Connecting through a web portal, using IE 8.


The RDP server I am connecting to is a VM instance running Win 2008 R2 with SP1

It is running RDP server version 6.1 (.7601.17514)


See the attached text doc for the VUGen error log snippet where it fails.


Is this environment supported? I am particulary interested in the RDP 6.1 server portion.


If it isn't supported is there something close that is?

I am able to run earler versions of LR though I assume that would not be helpful.

I am unable to record this from a Windows Server class machine because corporate security policy prohibits *mumble* -


I don't know all of the details, but the error I see is "Remote Desktop Web Connection ActiveX control could not be installed." There are no security policies or registry entries that I have access to with server level admin access that permit it to be installed. I'm working to have an exception granted so that I can record from a Windows Server class machine. It would run the same client version of RDP - 6.1


Other thoughts?


Thanks in advance for any light shed on this issue.