LoadRunner Practitioners Forum

LR11 Citrix

Chuck Hunt
Valued Contributor.

LR11 Citrix

I'm getting the below error when playing back a citrx/http protocol script.  I'm using citrix client 12.0.3 and have installed LR 11 Critical Update & Patch 3.  What could I be doing wrong?  Any ideas?


Error: Failed to get window size, wrong format.

Unable to detect client version.

Warning: Extension CitrixClientImpl.dll reports error -1 on call to function ExtPerThreadInitialize

Error: Vuser failed to initialize extension CitrixClientImpl.dll.

Vuser Terminated.

Acclaimed Contributor.

Re: LR11 Citrix


This may be the windows size in the rts,  this setting must match the client choosen size, but because of the dll mentioned, look like something else is going on, If I am not wrong there is a patch missing for this, please open a case with support.



Chuck Hunt
Valued Contributor.

Re: LR11 Citrix

I have an idea part of my problem could be the citrix session is loaded "seamless".  Although I would not expect to cause this error immediately upon starting the script replay.


On a side note. I am trying to automate a Java SWT/Eclipse application.  Is this possible with LR/Citrix protocol?


Re: LR11 Citrix

Hi Chuck,


Did you get a resolution to your problem?  I am having the same problem myself.





Honored Contributor.

Re: LR11 Citrix

It is possible if the application is published to Citrix, and you are not running a seamless session; It has to be a windowed session.


Have you tried scripting using the Java Record/Replay protocol without Citrix?

New Member.

Re: LR11 Citrix

I'm having the same issue. Did you get a resolution?

Trusted Contributor.

Re: LR11 Citrix



Earlier i have worked using CITRIX Protocol, faced this type of issues...




1. Check the CITRIX Client/Server version, whether it supports with LR11.0

2. Generate the script in Remote desktop, and also generate in your local machine. Execute both the scripts. Verify is there any difference.

    [Hope, even in client machine (Remote Desktop) you able to access the application using CITRIX]

3. Run Time Settings: Use Defaults

4. Verify the Recording Log and Reply Log, and compare the values where you are getting error.


Send us the logs as attachment, so that can give few more suggestions.



Krishna Seelam


Krishna Reddy Seelam
Super Contributor.

Re: LR11 Citrix

I know this is old but there's a solution in HP KB



The issue is with the [Citrix] statement in the default.cfg  file. It is not generated properly and needs to be fixed.