HPE Content Manager (HPE RM) Forum
Showing results for 
Search instead for 
Did you mean: 

Webdrawer Authentication issues (Again)

Senior Member

Webdrawer Authentication issues (Again)

TRIM 7.3.4 #5739


Webdrawer always has this issue. Only users that actually have logins to the server are able to connect. All other users get prompted and cannot login.


Tried all the known fixes. 


1) Reopen the isapi tool and recheck the dataset and template path (checked registry). 

2) Checked permissions on above path aswell as the webworkingpath permissions( even set both to everyone)

3) Tried removing and readding the webdrawaer as a virtual directory instead of an application.

4) Numerous switching of application pool identity 


Only way I have been able to get it functioning is to actually run the site as a specific user. 

Only clue I have is when testing the site connection states: access to template path is unknown add <domain>\computername$  though I have done this and still same issue.


Webdrawer is quickly becoming a pain. Webclient seems way more robust and just an easier solution.



Re: Webdrawer Authentication issues (Again)

Check your registry setting HKLM\Software\Hewlett-Packard


Make sure that the key TemplatePath data value is pointing to wherever your template directory is located.


Mine is C:\Program Files\Hewlett-Packard\HP TRIM\WebDrawer\template


Make sure that under the default we site you have anonymous authentication Enabled.


Give that a try.



Senior Member

Re: Webdrawer Authentication issues (Again)

Cheers Ralph


Template location is fine as anyone that can authenticate to the server itself can navigate around webdrawer ok. Domain Authentication DUN DUN no go. It seems to be authentication to the template folder itself but no account apart from local accounts can seem to get there.. Even added <domain>\Computername$ as the test suggests with no luck. Maybe needs adding to the TES similar to Webclient?


Not really after Anonymous authentication in this scenario. Pretty much would be the same as the current workaround I am using.

Re: Webdrawer Authentication issues (Again)

Try to set the share of the template folder to 'everyone' to see if it is a permission issue.

//Add this to "OnDomLoad" event