Data Protector Practitioners Forum

"Cannot open exchanger control device" error

Go to solution
Super Contributor.

"Cannot open exchanger control device" error

Being new to the data protector hardware and software it seems that I am running into every problem that is out there. The other night we were doing some upgrades to our core network switches and one of the Unix servers that is used by the dp. I wanted to be sure that the dp was not going to have any issues.


We had a backup that was still running that I cancelled using the GUI and to be on the safe side I did a "omnisv stop" on the windows server that runs the dp. After the upgrades I started the dp again and now one of the dp's does not want to respond.


When I try and do a scan I get the following two messages and nothing else. The agent is being invoked on the Unix box and that is where everything stops.




[Normal] From: "HP:Ultrium 5-SCSI_1_lewsd1"  Time: 1/31/2014 7:36:25 AM

      Media session 2014/01/31-3 started.


[Normal] From: "HP:Ultrium 5-SCSI_1_lewsd1"  Time: 1/31/2014 7:36:25 AM

      STARTING Media Agent "HP:Ultrium 5-SCSI_1_lewsd1"



This morning when I logged on to the dp I got the following messages.



[Critical] From: "HP:1x8 G2 AUTOLDR_lewsd1"  Time: 1/31/2014 1:55:16 AM

[90:59] : /dev/rchgr/autoch2

      Cannot open exchanger control device ([6] No such device or address)


[Critical] From: "Weekly All Systems Full-Incr1"  Time: 1/31/2014 1:55:17 AM

      None of the Disk Agents completed successfully.

      Session has failed.




I have rebooted the device, checked for stuck tapes and have done all the commands seen below but I am still not able to get a simple barcode scan of a tape done. Any ideas on this one?


omnisv stop

omnisv start

omnidbutil -show_locked_devs

omnidbutil -clear


ps -ef | grep omni

Micro Focus Expert

Re: "Cannot open exchanger control device" error

On the system '', from the command prompt, run


ioscan -fn


and look for 'autoch', similiar to this:


autoch       0  0/0/1/0.4.1     schgr     CLAIMED     DEVICE       HP      1x8 G2 AUTOLDR



The ' /dev/rac/c0t4d1' is the device address of the robotics (yours will be different than this example), this has to match how your Exchange Control Device is configured.  If you do not see 'autoch', or, if it says NO_HW then the Operating system does not see the device,   so DP has nothing to use


If you do see it, and it shows as CLAIMED, make a note of the device file


At the command prompt of the HPUX media agent, run the command


          /opt/omni/lbin/devbra -dev


which gives you a list of all SCSI-attached and SAN=attached devices, and in the group where 'Exch' is specified, verify the device address for the robotics


In the GUI, go to Devices and Media, click the |+| sign next to Devices, the |+| sign next to your Library "HP:1x8 G2 AUTOLDR_lewsd1", and get Properties for the Library.  Go to the Control tab, in the filed for the device file, you should see /dev/rchgr/autoch2.  If this does not match what you saw in the output from 'ioscan', you can either type in teh correct path for the device file, or click the down-arrow (which runs a 'devbra -dev' in the background), and pick the device file with the green check mark

Super Contributor.

Re: "Cannot open exchanger control device" error

Thank you for the response. I did the "ioscan -fn" and found nothing refering to "autoch".

Micro Focus Expert

Re: "Cannot open exchanger control device" error

Then, that is your problem.  Since the OS does not see the Exchanger control device, then DP is not going to be able to use it


I recommend that you cycle the power on your tape library, which sometimes will fix this problem, and, run the 'ioscsn -fn' again to see if you see the 'autoch' device again.  If not, check all your cables to make sure that nothing has worked loose, and everything is terminated.  Think about rebooting the Media Agent machine, although that did not go real well last time, but will give it a chance to rediscover the attached devices again, and run the 'ioscan -fn' again. 


However, the fact that you can't see the device at the OS-level takes it out of the possibility of this being a Data Protector issue