Data Protector Practitioners Forum

SQL Backup

Super Contributor.

SQL Backup

Good afternoon  all,


Trying to set up a backup of SQL on one of our servers and it does not pick up the Application Database in the drop down box below Client selection.


I have tried to type Default in manually but still no joy.


I get a dialogue box pop up saying


'The configuration check failed. Script failed. Cannot get information from remote host.' with the error code 12:8022.  I've seen this error on the forums but they seem to point to VM Ware or Oracle, neither of which are associated with this server.


If I click OK then another dialogue box pops up to configure MS SQL Server with the Client name as expected and the SID set to Default. Connection is Integrated authentication which we normally have set. I have tried with Windows authentication too. If I click OK on this dialogue box then another pops up with 'Integration cannot be configured.' with error code 12:8019. The details show the description *RETVAL*8010


I've tried adding a user impersonation but that doesn't resolve either.


We're running DP 7 on a W2008 R2 Std server.


The server with SQL on is also W2008 R2 Std running SQL 2005.


Anyone got some pointers?



Eblyn Solis
Acclaimed Contributor.

Re: SQL Backup

Hi Mondo,


Try this:


installa this fixs for SQL 2005, maybe help.



Please assign a kudo to this post, if you find it useful.
Micro Focus Expert

Re: SQL Backup

The literal translation of the error [12:8010] is


[12:8010] Internal error.
An internal error inside Data Protector has happened.
In case of MS SQL backup or configuration it is possible that internal error
is caused by MS SQL Server or because the MS SQL Server is not installed on the
client system.

In case of MS SQL backup or configuration, see if the MS SQL Server is properly
installed and configured on the client system.

1. Check debug.log file.
2. Restart OmniInet service on client with debug option and see the debug
file for details.


One thing to check on the SQL server is to run the command 'path' at the MS-DOS prompt, and make sure that there is a path to the [SQL_HOME}\bin folder


I checked my resources, and found nothing relating to this error whn doing a SQL integration, so I think that this is going to need to go to Data Protector support, so, we are looking at something we have not seen before


If Eblyn's suggestion does not help,


I would advise emptying the file on the SQL client


                      Program Data -> Omniback -> log -> debug.log


Please see the attachment for creating the debugs.  This is something support will ask you for anyway.  They will provide you with a FTP site to upload files

New Member.

Re: SQL Backup


Did you resolve this issue, I have the same problem any help would be really appreciated


Acclaimed Contributor.

Re: SQL Backup

In our environment this usually is a Name Resolution issue.

The SQL-Server has to be able to resolve its Hostname to IP and the other way around, if one doesn't work or gives different output the Integ won't work.

Same applies to the CellServer hostname.

Try to use the sql_bar Command on the DB-Server to configure the Integ, sometimes this gives an additional hint on what is wrong.

"sql_bar.exe config -dbuser:<user> '-password:<passwd>' -appsrv:<hostname> -instance:<instance>"

New Member.

Re: SQL Backup

This is what fixed this for me.  I was getting the "Intrigation could not be configured" (12.8019\RETVAL *8010)" errors when configuring the Backup job.  First I had HP verify the Debug logs, you guys know how then see if you get any "authtication errors" like below:

SQLSTATE:[42000] CODE:(229) MESSAGE:[Microsoft][ODBC SQL Server Driver][SQL Server]The SELECT permission was denied on the object 'msdb_version', database 'msdb', schema 'dbo'.

First checkyour "authtication type"  SQL Management Stuido. (Widnows Auth.  Vs SQL Auth.), make sure that matches your  configuration on DP.  Secondly, map  the admin account you are using on the SQL server (user mappingroles: db_owner, Puilic, RSExecRole, all 3 "SQLAgents..." ).  As the error above stated, the admin account I was using wasnt mapped correctly on ' (along setting the dbo Schema).    So in essance make sure your authtications matches on the DP Backup job as well as having that admin account mapped correctly (after verifying the specific error on the debug logs).

HP also had me set the admin account I was using to the Inet service credentials (as stated above), but that didnt help....however, I set it anyway as it may have helped with the connection and authtication after I correctly mapped SQL user roles and configured the backup job..