Data Protector Practitioners Forum

DP 8.1, HP P4000 and VSS Transportable backup (ZDB)

Go to solution
Regular Contributor.

DP 8.1, HP P4000 and VSS Transportable backup (ZDB)

Hi All,

I have a VMWare VM (Windows 2012) which was configured with a Raw Datastore Mapped virtual disk which is a P4000 storage system volume. I wanted to configure ZDB (Zero Downtime Backup), so that I can create a snapshot of this volume, mount it on the backup server (Windows 2012, Cell Manager with Media Agent) and copy it on tape.


Unfortunately the documentation does not provide any specific details on how this needs to be configured, but I managed to get the snapshot created on P4000 system during backup, however DP is unable to mount it on the backup system.


The backup system has iSCSI connection to the P4000 system and "sees" the original volume from the application server (in "Offline" mode), but the snapshot when created does not have any servers assigned, and thus will not be able to be mounted.


I also see this error message in the event log from HP LeftHand VSS Provider:

"Failed to connect snapshot LUN , 0x80001012 - Invalid parameter Transport. (Transport)."


It looks like the VSS provider is asked to mount the snapshot on the backup system, but has some kind of wrong parameter requested and fails.


Has anyone seen this before?

Regular Contributor.

Re: DP 8.1, HP P4000 and VSS Transportable backup (ZDB)

I found a solution, so I'm posting it here if you ever have to face it too.


I noticed that the snapshots created by Lefthand Hardware VSS provider didn't have any servers associated with it.


Even though I was advised by HP support that DP 8.1 supports LeftHand SAN IQ 10.0 and not higher I tried to install all versions of Lefthand VSS Provider including 10.5 and 11.0 on the backup server without any success.


It's not very well documented how this process should work, but by poking around with VSS I concluded that DP talks to VSS and then VSS talks to Lefthand VSS hardware provider to do the snapshot. I ran VSS debug which didn't reveal anything new.


However, after installing Lefthand VSS Provider version 11.0 I noticed there's a registry key:


Changing this to "1" and rebooting the server it enabled Hardware VSS Provider debug!


From the debug I could see that the snapshot is found, but cannot be mounted because it doesn't have any servers associated!


After that I installed the "unsupported" Hardware VSS Provider version 11.0 on the application server and new snapshots now have servers associated and now they could be mounted on the backup server.