Data Protector Practitioners Forum

Cannot mark file (error 1117) IO error With Data Protector 7.00 over ESX

New Member.

Cannot mark file (error 1117) IO error With Data Protector 7.00 over ESX



I'm trying using Dataprotector 7.00 with LTO3 IBM on a win2008 R2.

This windows is virtualised into esxi5.1 and the LTO3 is attached thru vmware SCSI storage .


This work fine on one site.


But on a new site, i can't backup..

I've got this message :

[Majeur] De : BMA@catequil.mrrl.local "IBM"  Heure : 29/10/2013 11:55:25
[90:161]     Impossible d'écrire la marque de fichier. ([1117] Impossible de satisfaire à la demande en raison d’une erreur de périphérique d’E/S. )

In english : 90:161, Cannot write file marker [1117] The request could not be performed because of an I/O device error.


But I can format media without problem.


I have compared parameters between the two site :

Presentation of the streamer to the VM into esx are identical (same SCSI, same controller, etc).

Into windows 2008R2 : Same device into device Manager, same driver version number.

Into Dataprotector, same adress, same data format, sames options.



I can't find RSM removable storage media on 2008, maybe it's because it's not installed :-)


I have tried to deactivate the device in device manager, then auto-configure device in DP. It created a device with target scsi0:0:0:  instead of tape0:0:0: but that doesn't work when I Format.


I have tried with 3 different and new tapes.


I know that Data Protector over vmWAre ESXi is not officialy supported, but why it can work on a site and not on the second site ?



Is anybody have an Idea ?


thanks by advance for your help.



P.S. This thread has been moved from Tape Backup (Small and Medium Business) to Data Protector Support and News Forum.  -HP Forum Moderaor

Acclaimed Contributor.

Re: Cannot mark file (error 1117) IO error With Data Protector 7.00 over ESX

A Format and a Backup are both doing Write operations on the tape, so, both should be working.  However, I can't say for sure if it is the same type of Write.  The error message is indicating a problem writing an end-of-file mark, but the Format is only writing a header file. Does that include an end-of-file mark?  Maybe, I am no expert on tape drives


This could be a driver issue, you can run 'devbra -dev' on both the working and non-working media agents to see if the 'Revision' field is the same


Are you in a  Storage Area Network (SAN) environment?  A lot of the time, problems with the Network Switch Router (NSR) or the Host Bus Adapter (HBA) will manifest themselves as hardware errors.  If you are in a SAN, you may want to update the firmware on all aspects of the SAN


Unlike a UNIX-based Media Agent, I can't do a normal test of loading a scratch tape, and using 'tar' to write, that functionality is not available on Windows


Have you used a utility like Library and TapeTools (LTT) to do a read/write test to the drive in question?  And, now that I think about it, did you use the same logical device to Format that you are trying to use for the backup?  if no, or, if you aren't sure, repeat your test, making sure that the same logical device is used

Unix Beheer
Regular Contributor.

Re: Cannot mark file (error 1117) IO error With Data Protector 7.00 over ESX

Anyone solved this problem?


We are facing identical issue's. We too have this problem, some sites are working some are not. But we haven't had a clue yet why.


Downgrading firmwares and drivers doensn't help either.