Client Support
cancel
Showing results for 
Search instead for 
Did you mean: 

set Send to mail in To recipient as Internal user

SOLVED
Go to solution
Highlighted
hafizahfini
Regular Collector

set Send to mail in To recipient as Internal user

Hi Gurus,

 

HPRM 8.1.1

 

How to set Send to mail in To recipient as Internal user only. As now, it will display all the location exist in the system. If i am using the saved search, it will take a long process just to get the that saved search where i need to open..all that..

 

 

Is there any setting inside it to make it as a default to show only internal user.

 

Your cooperation is highly appreciated. 

5 REPLIES
Neil Summers
HPE Expert

Re: set Send to mail in To recipient as Internal user

There should be a way to set the default search filters for this process. Let me have a look at it and get back to you.


Neil

Note: Any posts I make on this forum are my own personal opinion and (unless explicitly stated) do not constitute a formal commitment on behalf of HPE.

(Please state the version of CM you're using in all posts. At any given time, HPE are supporting approx. 30+ released versions)

HPE Software Support Online (SSO): https://softwaresupport.hpe.com/
Neil Summers
HPE Expert

Re: set Send to mail in To recipient as Internal user

Well it should be possible...but there's a bug. Here's an example of how it should work:

 

1. Set user options to send records using the HPRM e-mail form
2. Set user options so starting point when searching for locations is 'All items'
3. Right-click a record and send to mail recipient
4. Click the kwikselect button to select from HPRM locations
5. Hit F7 and go to the Filter tab
6. Deselect External and tick 'Set as default filters [Email recipient]'
7. Click OK and finish the process
8. Start the process again and the default filter setting should ensure that only Internal locations are displayed in the list.
 
There's an open CR for this issue:
QCCR2D54663: RM Client - Default filters not sticking when applied

Neil

Note: Any posts I make on this forum are my own personal opinion and (unless explicitly stated) do not constitute a formal commitment on behalf of HPE.

(Please state the version of CM you're using in all posts. At any given time, HPE are supporting approx. 30+ released versions)

HPE Software Support Online (SSO): https://softwaresupport.hpe.com/
hafizahfini
Regular Collector

Re: set Send to mail in To recipient as Internal user

Hi Neil,

 

Thanks for the reply.

 

So there's a bug according to you. The one build i mentioned for this problem is 7760. 

I have tested 7919, it still occurs!

 

Can you suggest anything to solve this issue..

Neil Summers
HPE Expert
Solution

Re: set Send to mail in To recipient as Internal user

I can think of a couple of options:

 

1. Don't "Send Records using the HP Records Manager Email form," i.e. turn off this user option, hence use the mail client's address book by default.

2. Change the user Search option "For Locations" from All Items to Search Dialog. Then when the user hits the kwikselect button, instead of HPRM retrieving a list of all locations it will present a search dialog. The user would then select the Filter tab and un-tick External before clicking OK. A couple more mouse clicks but it saves waiting for the whole list of locations to be populated.


Neil

Note: Any posts I make on this forum are my own personal opinion and (unless explicitly stated) do not constitute a formal commitment on behalf of HPE.

(Please state the version of CM you're using in all posts. At any given time, HPE are supporting approx. 30+ released versions)

HPE Software Support Online (SSO): https://softwaresupport.hpe.com/
hafizahfini
Regular Collector

Re: set Send to mail in To recipient as Internal user

Hi Neil, 

 

I will take your suggestion as solution. Hopefully customers happy about that.

 

Thank you for your suggestion!

 

 

//Add this to "OnDomLoad" event