Client Support
cancel
Showing results for 
Search instead for 
Did you mean: 

"Save global settings" is not available on a client newer than the server version?

SOLVED
Go to solution
Highlighted
raynebc
Member

"Save global settings" is not available on a client newer than the server version?

One of our Trim administrators asked me why he wasn't able to save global settings on our production dataset (Trim version 6.2.3.1147) after his client was updated to version 7.1.1132.  I couldn't find any documentation listing this as a limitation, so I was wondering if anybody could indicate whether this is by design or if it is intended to work?  Thanks in advance.

5 REPLIES
EWillsey
Honored Contributor
Solution

Re: "Save global settings" is not available on a client newer than the server version?

You can't really use a 7.1 client and talk to a 6R2 backend.  It's not supported.

 

The global settings capabilities between the two versions are completely different... different format, options, etc.  

 

You shouldn't really even try doing this in a production environment.

raynebc
Member

Re: "Save global settings" is not available on a client newer than the server version?

Alright.  It couldn't hurt for the documentation to be updated to reflect this, should I raise an enhancement request?

EWillsey
Honored Contributor

Re: "Save global settings" is not available on a client newer than the server version?

I guess so.  Though it's pretty much always assumed that things only work properly if all parts of the system are using the same build numbers.  Otherwise weird things can happen.

Grundy
Honored Contributor

Re: "Save global settings" is not available on a client newer than the server version?

 


raynebc wrote:

should I raise an enhancement request?


 

No, this isn't something that R&D will provide support for.

We have never supported mixed builds in any environment except for short-term upgrade purposes.

 

This unsupported configuration is covered in documentation under a few places, TRIMCon2Con, TRIMReleaseNotes etc...

 



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

INFORMOTION.com.au
Neil Summers
HPE Expert

Re: "Save global settings" is not available on a client newer than the server version?

Extracts from TRIM7.1_Install.pdf:

 

"...Mixed environments

To minimize downtime in very large organizations, HP TRIM 7.x runs in mixed environments, i.e. environments with clients and servers using the same version of HP TRIM (e.g. 7), but different build numbers. 2.0.x represents the build number..."

 

and

 

"...However, as a general rule, HP TRIM clients in mixed environments must have build numbers the same or later than the HP TRIM Workgroup Server/s they communicate with.For example, with a Workgroup Server on version 7.1.0.75, the clients should not use any build of version 7.0 or 6. However, they could use HP TRIM 7.1.0.92, for example. Without this ability, downtime would include the time it takes to roll out HP TRIM 7 to all clients..."


Neil

Note: Any posts I make on this forum are my own personal opinion and (unless explicitly stated) do not constitute a formal commitment on behalf of HPE.

(Please state the version of CM you're using in all posts.

HPE Software Support Online (SSO): https://softwaresupport.hpe.com/
//Add this to "OnDomLoad" event