The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday noon (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday noon (PST)
cancel
Showing results for 
Search instead for 
Did you mean: 

Title Word Searching in Content Manager 9

SOLVED
Go to solution
Highlighted
Bob-P
Acclaimed Contributor

Title Word Searching in Content Manager 9

I have a new installation of Content Manager 9 on which I am performing preliminary investigations into code changes needed as a result of a planned upgrade from version 6.  The installation seems to be mostly working and I have partially emulated our legacy systems model of Classifications, Folders etc. Using the desktop interface I have created document records, checked in files etc.  Unfortunately searching by "Title Word" does not work.  The word index was regenerated from Enterprise Studio and if I search the index words they are all visible.  However record searches based on "Title Word" return no results, but searches by "Free Text Title" locate documents without problem.  I also note that the "Structured Title" is blank but I have no idea what that is!

This problem probably stems from an omission or error in configuration but finding it has defeated me.  Can anyone help?

Regards

Bob

 

 

4 REPLIES
Greg Fraser_1
HPE Expert

Re: Title Word Searching in Content Manager 9

Have you tried rebuilding the index?

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
Bob-P
Acclaimed Contributor

Re: Title Word Searching in Content Manager 9

Yes, the indexes have been rebuilt the indexed words match what I would have expected.  Oddly, if I run SQL profiler against the database I don't see any activity when searching by "Title Word" but I do if searching by "Free Text Title".

EWillsey
Honored Contributor
Solution

Re: Title Word Searching in Content Manager 9

In your system administration options, ensure that your title word searches are conducted without IDOL.  Or, ensure IDOL is functioning.

Bob-P
Acclaimed Contributor

Re: Title Word Searching in Content Manager 9

Thanks for your reply, this was the problem. IDOL had been selected for title searches but IDOL was not configured.  I actually spotted this yesterday having noticed that there were no queries hitting the database when searching by title.  It suggested that some other agent was supposed to be performing the search but was failing.

//Add this to "OnDomLoad" event