cancel

Thin Office Integration Error

Highlighted
thelegend7
Acclaimed Contributor

Thin Office Integration Error

Hey,

after installing the Thin Office Integration x86 (8.1.0.7239) I get the following error when opening Word, Excel etc.:

 

Value cannot be null. Parameter name: phoenixBaseUrl 

 

Also if I click OK to this error and then try and use the Open option from the HP RM ribbon I get:

 

Object Reference Not set to an instance of an object.

 

Have tried reinstalling, modifying the WebClient Url in the preferences file on the client machine and have even successfully changed the dataset in the hpRMServiceAPI.config. The web client works fine in IE/Chrome but just cant seem to connect via Office.

 

Problem exists for both 2010 and 2013 x86 versions.

 

Any ideas?

 

Cheers.

8 REPLIES
Greg Fraser_1
HPE Expert

Re: Thin Office Integration Error

Hi, do you have the Webclient installed?

 

The Thin client requires webclient to be able to integrate.

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
thelegend7
Acclaimed Contributor

Re: Thin Office Integration Error

Yes, as I mentioned it functions on its own without issue. That is true for both the classic and the MVC one.
Greg Fraser_1
HPE Expert

Re: Thin Office Integration Error

Sorry should ahve read more than the first paragraph.

 

What OS are you running?

 

Also do you need to configure the integration to point to th correct dataset \ webclient instance?

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
thelegend7
Acclaimed Contributor

Re: Thin Office Integration Error

Win7 SP1 x64.

 

I have configured the web client URL as part of the Thin Office installer and the web client config itself on the servers points to the correct dataset. Navgiating direct to the web client URL on the same machine allows me to browse/search recrods etc. and on desktops where the RM full client is installed the Office integration works but the Thin integraiton piece does not.

Jane Hay
Regular Collector

Re: Thin Office Integration Error

Hi,
Sorry can't assist with your posted issue, but I noticed you're using 8.1.0 7239. I could be wrong but I thought this particular build was discovered to have a potentially serious security related issue. I don't want to alarm you, but I would recommend checking the later 8.1 patch releases for details (I believe there have been 2 since 7239). I'm still at least a few weeks away from being able to test the web client and thin client (with 8.1.0 7275).
Jane Hay
Regular Collector

Re: Thin Office Integration Error

Http://h30499.www3.hp.com/t5/HP-Records-Manager-and-HP-TRIM/HP-RM-TRIM-Current-Builds-Updated-15th-Sep/m-p/6607752#M4435

Have a look at the above post, it confirms 7239 was pulled from release. Sorry to be the bearer of bad news, but I'm sure you'd rather someone told you.
thelegend7
Acclaimed Contributor

Re: Thin Office Integration Error

Hi Jane,

 

Thanks for the response. Wasn't aware of that but luckily we are only in a POC stage. I will swap over though and hopefully the newer builds will help with my issues.

 

Cheers.

thelegend7
Acclaimed Contributor

Re: Thin Office Integration Error

So in case anyone else has ran into this issue I thought I'd post back an update.

 

Install 7275 as per Jane's post but unfortunately I got the same error. Did some digging and it seems as though the installer fails to set the Web client Url despite the fact that it was entered during the installation. I even tried installing via the command line and forcably setting the property which is recognised but then later in the installation it runs the following, which i think is overwriting the property.

 

Skipping action: SetPHOENIX_URL_INT (condition is false)

 

I also tried setting this parameter in an attempt to force it to set the param but to no avail. 

 

what i did discover was that the Office Add-in reads from a user specific preferences file located in  C:\Users\username\AppData\Roaming\Hewlett-Packard\HP TRIM\OfficeIntegration and not the one in the Program Files directory. Editing this file and setting the Web Client Url did the trick for meand the integration now works. Its a bit of a hack and would hope that someone from the Product Team reads this and fixes it but at least its a workaround for now.

 

Does anyone know if the Outlook Integration is with the full client only and does not work with the Thin Client Integration?

//Add this to "OnDomLoad" event